Water Intoxication quest in Bastard's Wound bugged?

  • Crusader Kings II Expansion Subscription

    Subscribe to the CK II Expansion and enjoy unlimited access to 13 major expansions and more!


  • Crusader Kings III Available Now!

    The realm rejoices as Paradox Interactive announces the launch of Crusader Kings III, the latest entry in the publisher’s grand strategy role-playing game franchise. Advisors may now jockey for positions of influence and adversaries should save their schemes for another day, because on this day Crusader Kings III can be purchased on Steam, the Paradox Store, and other major online retailers.


    Real Strategy Requires Cunning

Fink15

Recruit
24 Badges
Sep 22, 2017
4
0
  • Stellaris: Synthetic Dawn
  • Stellaris: Megacorp
  • BATTLETECH: Flashpoint
  • Shadowrun: Hong Kong
  • Shadowrun: Dragonfall
  • Shadowrun Returns
  • Stellaris: Distant Stars
  • Stellaris: Apocalypse
  • Stellaris: Humanoids Species Pack
  • Age of Wonders III
  • Tyranny - Bastards Wound
  • Tyranny - Tales from the Tiers
  • Crusader Kings II
  • BATTLETECH
  • Stellaris - Path to Destruction bundle
  • Stellaris: Leviathans Story Pack
  • Stellaris: Digital Anniversary Edition
  • Tyranny: Archon Edition
  • Tyranny: Archon Edition
  • Hearts of Iron IV: Cadet
  • Stellaris
  • Magicka 2
  • Pillars of Eternity
  • Magicka
Tycho in the farming area gives me this quest to find evidence of plant tampering and I'm told to talk to the other named characters in the zone, but none of them provide dialogue options for the quest. Am I missing something?
 

sou1seeker

Recruit
Nov 11, 2017
2
0
Have the same bug.
I've finished BW main story line and tried to do that quest.
Tycho asks to investigate the problem but there is nothing you can do in that area.
You can't ask neither Oceans-Fury nor Lunet/Kleitos and no evidence to be found.
Though I've loaded my savegame just after completion Tide Together and this way I'm able to complete this quest.
But I've already done Wound's Oldwalls twice and don't have desire to do it third time...
Very bugged location I must admit :(

UPD. Okay now, I have tried reloading prior to speaking with Reef-Talon in the Abyss and on this stage this quest is completeable.
So, if you are able to load your game and neglect some of your progress, you can complete this quest.
 
Last edited: