Update on Paradox Game Launcher's support on Windows 7, 8 & 8.1

  • We have updated our Community Code of Conduct. Please read through the new rules for the forum that are an integral part of Paradox Interactive’s User Agreement.

LordChristof

Communications Project Manager
Paradox Staff
Moderator
Jan 29, 2020
13
20
Hello everyone!

Last week, we deployed version 2023.14 of the Paradox Game Launcher. With this version we are no longer supporting Windows 7, 8, and 8.1. We wanted to give you all some more information on how this decision came about and what it means for those of you still using older Windows OS versions.

The above change is motivated by two main reasons:
  1. Windows 7, 8 and 8.1 no longer receive paid security updates as of January 2023, and are therefore more prone to being affected by malware. That introduces security risks for the development of the Launcher that have the potential to put both our systems and those of our players at an unnecessary risk.
  2. Steam will be pulling support for Windows 7, 8 and 8.1 in January 2024, and so it’s no longer valid for us to support the Launcher on these systems.

What does it mean for your experience?
  • Since we will no longer support the Launcher for Windows 7, 8 and 8.1, it means that the future versions of our Launcher will *not* run under these old OSes.
  • Any launcher update beyond that point will cause it to stop working on above systems, and will, in turn, make it not possible to launch our games. Some of you who had their launchers update are likely experiencing that already.

Can I still use an older version of the launcher that is compatible with Windows 7, 8 or 8.1?
  • While we don’t support version rollbacks with our Launcher, you can use a manual workaround:
    • In order to run an older version of the launcher, the easiest way to do it is to rename the folder of the version you want to keep (in this case %LocalAppData%\Programs\Paradox Interactive\launcher-v2.2023.13.1) to instead be named launcher-v2.2099.99. This will cause it to be chosen as the latest version. Launcher updates should subsequently fail - Which is probably what you want.
    • You can download the folder with Version 2023.13 installer that is still compatible, attached to this message. Install it and rename the folder as per instructions above.

Some final information:
  • We strongly recommend you consider doing the free OS update to supported Windows versions, like Windows 10 or 11. Both for Launcher compatibility and personal security.
  • In the coming weeks, we’ll update minimal requirements for our games and DLCs on our storefronts, to reflect this change.
  • Going forward, we’ll do our best to communicate changes like that ahead of time with you all. If any OS support is stopped for our Launcher in the future, we’ll do our best to communicate it ahead of time and we intend to introduce a feature to the Launcher which will freeze automatic updates on systems it no longer supports.

If you have any questions regarding the above, don’t hesitate to ask. We’ll do our best to answer.
 

Attachments

  • 2023.13.1-win-prod.zip
    114,6 MB · Views: 0
Last edited:
  • 4
  • 1Like
Reactions:
Could a download of this folder be provided: %LocalAppData%\Programs\Paradox Interactive\launcher-v2.2023.13.1 ? I do not think the launcher installs it any more.
 
  • 1Love
Reactions:
Could a download of this folder be provided: %LocalAppData%\Programs\Paradox Interactive\launcher-v2.2023.13.1 ? I do not think the launcher installs it any more.
Each game team supplies a version of the launcher with that game's download. What version that is varies wildly. I think what is needed is a separate installer of that 13.1 version, with the updater removed.

If you have any questions regarding the above, don’t hesitate to ask. We’ll do our best to answer.
The same situation seems to obtain with MacOS , it does run on 10.13 or earlier at least. Older Mac hardware cannot run newer MacOS versions. Is a similar approach intended?
 
Each game team supplies a version of the launcher with that game's download. What version that is varies wildly. I think what is needed is a separate installer of that 13.1 version, with the updater removed.


The same situation seems to obtain with MacOS , it does run on 10.13 or earlier at least. Older Mac hardware cannot run newer MacOS versions. Is a similar approach intended?

Ah yeah, an easy fix of this would be really nice. After all many of the older games where sold for windows 7/8 and it is still listed in their minimum requirements.
 
Ah yeah, an easy fix of this would be really nice. After all many of the older games where sold for windows 7/8 and it is still listed in their minimum requirements.
The "fix" in this case will be that the minimum requirements will be changed, as stated in OP:
In the coming weeks, we’ll update minimal requirements for our games and DLCs on our storefronts, to reflect this change.
 
It would probably be good to have the launcher also alert when it does not detect the proper requirements. Otherwise quite a few people will just be confused as it suddenly stops working.

Sorry, but I have to ask: Did you actually read the OP?

Going forward, we’ll do our best to communicate changes like that ahead of time with you all. If any OS support is stopped for our Launcher in the future, we’ll do our best to communicate it ahead of time and we intend to introduce a feature to the Launcher which will freeze automatic updates on systems it no longer supports.
 
Yeah, but no reason not to add that function to the launcher now?
If that feature would exist I'm sure they would have added it already.
 
Hi everyone o/

I've attached a file with version 2023.13 installer to the first post. It's a manual installer for the last launcher version compatible with Windows 7, 8 and 8.1. You can download it, install and rename the folder as per instructions in the original thread.