• We have updated our Community Code of Conduct. Please read through the new rules for the forum that are an integral part of Paradox Interactive’s User Agreement.


69 Badges
Sep 3, 2015

I've been waiting too long for such a mod to appear for Imperator, and I had some free time last weekend.

So, here you go: a functional Shattered World mod generator Download

Please send me any feedback you might have, and definetely let me know if there are any issues.

Also, please feel free to contribute to the code.
It's open source, which means it's not my code, it's our code, just like glorious commu-... wait, no, not like that.

GitHub Repository
^ Check the README for instructions

It's available on all operating systems (although I only tested it on Linux)

Once enough of you give their feedback I'm gonna also upload one or two results to the Steam Workshop for convenience, but for now, consider this a beta.

By the way, in case it's not clear from the instructions, an example run:
./ImperatorShatteredWorldGenerator -d /games/linux/Steam/steamapps/common/ImperatorRome/ -n "Shattered World" -s 8897 --capital-population 11 --city-pops-min 2 --city-pops-max 16 --rng-countries 0
This is where I realize I have no idea how to use this. But looks fun when it is more accessible to code illiterate people
You can open a CMD (or PowerShell) window in the folder where you extracted the tool, and paste the example from GitHub. An "out" folder will be generated with the mod inside.

To open the cmd/ps in that dir press shift and right click on a blank space in that folder window and there should be an option to open it.

After you're successful, you should start customising the values of th arguments as per the table on the GitHub page
I got the PowerShell opened from inside the folder, but how do I get it to run the tool? I typed in "ImperatorShatteredWorldGenerator" without the quotes, and then tried run in front of it, but both tries did not work. I am a complete noob when it comes to command and such.
Try something like

./ImperatorShatteredWorldGenerator -d "C:\Program Files (x86)\Steam\steamapps\common\ImperatorRome" -n "Shattered World" -s 8897 --capital-population 11 --city-pops-min 2 --city-pops-max 16 --rng-countries 0

but make sure that the "C:\Program Files (x86)\Steam\steamapps\common\ImperatorRome" game location is correct, otherwise change it as necessary

I'm gonna make some updates tot he tool to make it easier to use. One of this days. And I'll also write a proper guide to use it. I'm gonna avoid making the user have to open a CMD/terminal window, at least on Windows.
Thanks! It started, but threw this error:

Generating a shattered world using the seed '8897'...

Unhandled Exception: System.Runtime.Serialization.SerializationException: Wrong number of CSV fields
at NuciDAL.IO.CsvFile`1.ReadLine(String line)
at System.Linq.Enumerable.WhereSelectArrayIterator`2.MoveNext()
at NuciDAL.Repositories.CsvRepository`2.LoadEntitiesIfNeeded()
at NuciDAL.Repositories.CsvRepository`2.GetAll()
at ImperatorShatteredWorldGenerator.Service.EntitiesLoader.LoadCities()
at ImperatorShatteredWorldGenerator.Service.EntityManager.GetCities()
at ImperatorShatteredWorldGenerator.Service.EntityManager.GetCityIds()
at ImperatorShatteredWorldGenerator.Service.ShatteredWorldGenerator.GenerateCities()
at ImperatorShatteredWorldGenerator.Service.ShatteredWorldGenerator.Generate()
at ImperatorShatteredWorldGenerator.Program.Main(String[] args)
Getting the same error as the one above me, with these parameters: .\/ImperatorShatteredWorldGenerator -d \Steam\steamapps\common\ImperatorRome -n "Shattered World 1" Really want to test this out, good job!

Same error with this line as well: ./ImperatorShatteredWorldGenerator -d "D:\Steam\steamapps\common\ImperatorRome" -n "Shattered"
Last edited:
Sorry for not replying sooner.

Apparently the error originates from one of the game files itself (provinces_setup.csv). There are a few problems with some of the lines, and was introduced only in 1.1 (I was still using 1.0.* Pompey, that's why I didn't notice this error myself)

Unfortunately the errors seem to still be there in 1.2
I'll let the devs know and see if they can fix it. If not, I'll have to find some way to work around those problems

I've filed a bug report: https://forum.paradoxplaza.com/forum/index.php?threads/i-r-csv-errors-in-provices_setup-csv.1199337/
Last edited:
Thanks for the update. Good call on the bug report ! Anxiously waiting
Hello guys,

Unfortunately I have not been playing Imperator anymore in a very long time.
I've not updated this tool anymore, and I'm not sure if the game limitations and issues that caused problems with the tool are now solved or not.

I'm not sure about when I will get the tool working again, as my time is quite limited and I'm not really interested in playing Imperator for the forseeable future.
Eventually I will, though. I just don't know when.

In any case, any of you who has C# knowledge and is willing to work on this tool, is welcome, and I will even provide support. The source code is all on GitHub (link in the first post).