Surviving Mars - Attempting to install mods results in file system error [Win10 Store ver]

Surviving Mars - Attempting to install mods results in file system error [Win10 Store ver]

  • Crusader Kings III Available Now!

    The realm rejoices as Paradox Interactive announces the launch of Crusader Kings III, the latest entry in the publisher’s grand strategy role-playing game franchise. Advisors may now jockey for positions of influence and adversaries should save their schemes for another day, because on this day Crusader Kings III can be purchased on Steam, the Paradox Store, and other major online retailers.


    Real Strategy Requires Cunning

thefirebirdman

Recruit
Jul 23, 2020
1
0
Hey! we're investigating this with our mods team. Thanks for reporting!
I am having this same problem as well over a full year later. Very disappointing that it looks like someone that might have been able to help with this issue (Azurespectre) posted the above in June of last year and then never replied again. Was this issue addressed in another thread? I've seen some workarounds posted but I just downloaded the game to PC through my GamePass Ultimate sub, purchased all the DLCs and then tried to start adding mods after launching the game.

My experience is a little different in that I already previously played the game on Xbox, already have a Paradox account setup on Xbox and have been playing with mods for quite a while. As soon as I launched the game on my pc and logged into my Paradox account I immediately began getting error messages the mods I added previously (on the xbox console) could not be added citing the same error message from the OP. Presumably this is occurring because the new game instance on my PC is trying to mirror what I already had setup on my Xbox console.

I get one pop-up error message for every mod I have installed on the Xbox which is about 60 mods. If I click to acknowledge all the error messages it eventually clears them until my mods list shows 0 installed. From that point if I try to install anything I get the error message. Additionally if I close the game and re-open it, the process starts all over again, getting prompted 60+ times for mods that are already in place that can't be installed in the PC instance.

So unless I uninstall all the mods from the console, I'm going to get spammed with these errors every time I load the game. And even if I do, I can't then install mods on the PC instance. So this is still pretty game breaking and again its really disappointing there was initial responsiveness to look into this and then just nothing for over a year. If anyone has an update on this, I'd really appreciate it.
 
Last edited:

Fred (SAS)

Recruit
Jun 1, 2020
2
0
Officially, Dunno but you could probably change the permissions on the profile folder to make it writable, and that should "fix" the issue.
I fixed the issue on my part by purchasing the Steam version. Everything now works flawlessly. :(