TheVenge

Corporal
24 Badges
Sep 10, 2012
28
1
  • Warlock 2: The Exiled
  • BATTLETECH
  • Crusader Kings III
  • Age of Wonders: Planetfall - Revelations
  • BATTLETECH: Heavy Metal
  • Age of Wonders: Planetfall
  • BATTLETECH: Season pass
  • BATTLETECH: Flashpoint
  • Shadowrun: Hong Kong
  • Shadowrun: Dragonfall
  • Shadowrun Returns
  • Age of Wonders
  • Age of Wonders III
  • Crusader Kings II
  • Stellaris: Leviathans Story Pack
  • Stellaris: Digital Anniversary Edition
  • Tyranny: Archon Edition
  • Hearts of Iron IV: Colonel
  • Hearts of Iron IV: Cadet
  • Stellaris
  • 500k Club
  • Warlock 2: Wrath of the Nagas
  • Warlock: Master of the Arcane
  • Europa Universalis IV
In my last three games where I play starting from the Elven plane, I encounter a point in the latter part of the early game where I am starting to terraform the randomness away from the generated map. There is what seems to be a set of 3 or so water tiles on the plane that will crash me to Windows if I try to raise it. Happens when I am casting Raise the Land or Greater Lands Raising; I've tried verifying local cache, deleting and re-downloading local content, and so on. I have not encountered it raising land from existing land tiles.

The crash to Windows is a little box that is titled "Application aborted!" and in the body of it says "ArrayCacheIdx<767>:eek:verflow 767"

OS: Windows 7
Mods running: none
Picks: Archmage, Trader, Elven Plane
Race: Elves
World size: Large (but I've had it happen on Medium)
Mode: Sandbox
City Limit: disabled

DxDiag and some screenshots are attached. Let me know if you want to see anything else. I'm going to try updating video drivers after I make this post but do not believe that will resolve. I'll post here if it does :)
View attachment DxDiag.txt
Warlock2-error01.jpg
Warlock2-error02.jpg
 
Last edited:

TheVenge

Corporal
24 Badges
Sep 10, 2012
28
1
  • Warlock 2: The Exiled
  • BATTLETECH
  • Crusader Kings III
  • Age of Wonders: Planetfall - Revelations
  • BATTLETECH: Heavy Metal
  • Age of Wonders: Planetfall
  • BATTLETECH: Season pass
  • BATTLETECH: Flashpoint
  • Shadowrun: Hong Kong
  • Shadowrun: Dragonfall
  • Shadowrun Returns
  • Age of Wonders
  • Age of Wonders III
  • Crusader Kings II
  • Stellaris: Leviathans Story Pack
  • Stellaris: Digital Anniversary Edition
  • Tyranny: Archon Edition
  • Hearts of Iron IV: Colonel
  • Hearts of Iron IV: Cadet
  • Stellaris
  • 500k Club
  • Warlock 2: Wrath of the Nagas
  • Warlock: Master of the Arcane
  • Europa Universalis IV
No problem. I also updated drivers and still see the issue. Updated dxdiag attached as well as the save game. I'm not familiar with the structure of the save games for this game so I'm attaching what I think are the files you need. Let me know if I got it wrong...

Actually, when I try to attach the files for the saves the attachment manager thing tells me all 3 files are "invalid file" and won't attach. I'm trying to get them from "...\Steam\userdata\<your account ID>\205990\remote\saves" -- is this not correct?

View attachment DxDiag.txt
 

TheVenge

Corporal
24 Badges
Sep 10, 2012
28
1
  • Warlock 2: The Exiled
  • BATTLETECH
  • Crusader Kings III
  • Age of Wonders: Planetfall - Revelations
  • BATTLETECH: Heavy Metal
  • Age of Wonders: Planetfall
  • BATTLETECH: Season pass
  • BATTLETECH: Flashpoint
  • Shadowrun: Hong Kong
  • Shadowrun: Dragonfall
  • Shadowrun Returns
  • Age of Wonders
  • Age of Wonders III
  • Crusader Kings II
  • Stellaris: Leviathans Story Pack
  • Stellaris: Digital Anniversary Edition
  • Tyranny: Archon Edition
  • Hearts of Iron IV: Colonel
  • Hearts of Iron IV: Cadet
  • Stellaris
  • 500k Club
  • Warlock 2: Wrath of the Nagas
  • Warlock: Master of the Arcane
  • Europa Universalis IV
Yeah I feel a little dumb for not thinking of that this morning, and did on my drive home today. Was hoping to get home post it before you said anything :)

Anyway, here's the zip. Password is "warlock2" so as to avoid screwy things with AV software.

View attachment vengeant_saves.zip
 

TheVenge

Corporal
24 Badges
Sep 10, 2012
28
1
  • Warlock 2: The Exiled
  • BATTLETECH
  • Crusader Kings III
  • Age of Wonders: Planetfall - Revelations
  • BATTLETECH: Heavy Metal
  • Age of Wonders: Planetfall
  • BATTLETECH: Season pass
  • BATTLETECH: Flashpoint
  • Shadowrun: Hong Kong
  • Shadowrun: Dragonfall
  • Shadowrun Returns
  • Age of Wonders
  • Age of Wonders III
  • Crusader Kings II
  • Stellaris: Leviathans Story Pack
  • Stellaris: Digital Anniversary Edition
  • Tyranny: Archon Edition
  • Hearts of Iron IV: Colonel
  • Hearts of Iron IV: Cadet
  • Stellaris
  • 500k Club
  • Warlock 2: Wrath of the Nagas
  • Warlock: Master of the Arcane
  • Europa Universalis IV
Just encountered the same crash and error code when trying to LOWER the Lands. If it matters, it's the same game as the one I have attached saves for above. Terraforming is SO integral to my play style, so hopefully this gets fixed :( Let me know if you need additional info.

EDIT -- while playing with a friend in a multi-player game I ran across it again, except the code is 761 instead of 767 that it is in single player. I have not done extensive testing yet but all of these instances have occurred while casting raise or lower lands in the Elven Lands that I started with (Elven Lands 2-pick).

EDIT2 -- we tried my friend casting the spell instead of me, same areas on the west and east of my city in the middle of the water. Same 761 crash.
 
Last edited:

TheVenge

Corporal
24 Badges
Sep 10, 2012
28
1
  • Warlock 2: The Exiled
  • BATTLETECH
  • Crusader Kings III
  • Age of Wonders: Planetfall - Revelations
  • BATTLETECH: Heavy Metal
  • Age of Wonders: Planetfall
  • BATTLETECH: Season pass
  • BATTLETECH: Flashpoint
  • Shadowrun: Hong Kong
  • Shadowrun: Dragonfall
  • Shadowrun Returns
  • Age of Wonders
  • Age of Wonders III
  • Crusader Kings II
  • Stellaris: Leviathans Story Pack
  • Stellaris: Digital Anniversary Edition
  • Tyranny: Archon Edition
  • Hearts of Iron IV: Colonel
  • Hearts of Iron IV: Cadet
  • Stellaris
  • 500k Club
  • Warlock 2: Wrath of the Nagas
  • Warlock: Master of the Arcane
  • Europa Universalis IV
Good news! I think I found the problem. In another game (multi-player, in case it matters but I don't think it does. I will have to get farther into a new, single player game to confirm), I once again started on an Elven Lands plane. This time I did not loot the monster lairs in the water, leaving them alone until I could raise land. I raised land around them with no issues, but as soon as I raised land on them (I looted them with an airship first), crash. This applies to both Greater and single cast versions of raise land. I didn't have any mountains but I would surmise that my Lower the Lands crashes mentioned above are likewise due to the combined factors of Elven Lands + a previously existing lair.

So to recap: crash appears to be due to combination of trying to raise or lower land over tiles previously containing monster lairs at the start of the game, but only on Elven Lands. I haven't been able to reproduce this on other plane types, though admittedly I have not tried more than a few turns into a Dremer plane. I have never had the issue raising/lowering on Ardania, Elemental, or Dead planes.
 

TheVenge

Corporal
24 Badges
Sep 10, 2012
28
1
  • Warlock 2: The Exiled
  • BATTLETECH
  • Crusader Kings III
  • Age of Wonders: Planetfall - Revelations
  • BATTLETECH: Heavy Metal
  • Age of Wonders: Planetfall
  • BATTLETECH: Season pass
  • BATTLETECH: Flashpoint
  • Shadowrun: Hong Kong
  • Shadowrun: Dragonfall
  • Shadowrun Returns
  • Age of Wonders
  • Age of Wonders III
  • Crusader Kings II
  • Stellaris: Leviathans Story Pack
  • Stellaris: Digital Anniversary Edition
  • Tyranny: Archon Edition
  • Hearts of Iron IV: Colonel
  • Hearts of Iron IV: Cadet
  • Stellaris
  • 500k Club
  • Warlock 2: Wrath of the Nagas
  • Warlock: Master of the Arcane
  • Europa Universalis IV
Quick edit to the above -- once I looted the first of them, I couldn't raise land around them without crashing. Theorizing that there's a tie to having looted any of the sea tiles.

EDIT again -- ugh, my "hypothesis" above wasn't it. Tried starting a new game on the Elven Plane and leaving the monster lairs alone and it STILL eventually broke on me. Maybe it breaks after a certain number of tiles raised and/or lowered, because it has alway broken a few casts in -- never on the first few.
 
Last edited:

TheVenge

Corporal
24 Badges
Sep 10, 2012
28
1
  • Warlock 2: The Exiled
  • BATTLETECH
  • Crusader Kings III
  • Age of Wonders: Planetfall - Revelations
  • BATTLETECH: Heavy Metal
  • Age of Wonders: Planetfall
  • BATTLETECH: Season pass
  • BATTLETECH: Flashpoint
  • Shadowrun: Hong Kong
  • Shadowrun: Dragonfall
  • Shadowrun Returns
  • Age of Wonders
  • Age of Wonders III
  • Crusader Kings II
  • Stellaris: Leviathans Story Pack
  • Stellaris: Digital Anniversary Edition
  • Tyranny: Archon Edition
  • Hearts of Iron IV: Colonel
  • Hearts of Iron IV: Cadet
  • Stellaris
  • 500k Club
  • Warlock 2: Wrath of the Nagas
  • Warlock: Master of the Arcane
  • Europa Universalis IV
Sadly, almost 6 months later and the issue still exists. :( Just started a new game a few days ago and when I went to Greater Lands Raising to make a whole section of my tiny plane habitable, boom. It's a game breaker, as well as an enthusiasm breaker.