• We will be taking the forums down for scheduled maintenance on 12 August 2020 at approximately 3PM CDT (8PM UTC / 10PM CEST), this downtime is currently estimated to last around 1 hour.
  • Pre order now!

    Paradox Development Studio brings you the sequel to one of the most popular strategy games ever made! Crusader Kings III is soon upon us and you can pre order it today!


    Releasing September 1st 2020
Aug 2, 2012
4
0
registered my account with the forums, activated my beta key. I can log into the forums but the game will not recognize my password.
 

unmerged(376826)

General
Demi Moderator
1 Badges
Sep 12, 2011
2.032
0
  • Sword of the Stars
Are you speaking of the Paradox Plaza forums or the salemgame.com forum? If you haven't done so, go through the procedure of transferring your log in credentials over to the new log in server. If not, make sure you do so. http://login.salemgame.com/

Select the "Transfer Old Paradox Account" option. It will prompt you to enter your user name and password as well as verify acceptance of the end-user license agreement. Once done, you should be able to log into the new forums as well as log into the game. (Note: you might need to log into the forums once to get things working right, or so I've heard from at least one person who's had trouble logging in.)
 

unmerged(376826)

General
Demi Moderator
1 Badges
Sep 12, 2011
2.032
0
  • Sword of the Stars
I'll see if I can get one of the dev's attention on this. I've only seen one other complaint on this, though, and logging into the forums once fixed it.

edit: If you can log into the forums on salemgame.com, feel free to post the same thread there. Loftar, the code gnome, has been unable to access the Paradox forums. Otherwise I'll see if I can get an answer if you don't want to.

One additional thought: are you using the client from the link on the registration page? http://plymouth.seatribe.se/java/salem.jnlp
 

unmerged(376826)

General
Demi Moderator
1 Badges
Sep 12, 2011
2.032
0
  • Sword of the Stars
I don't know why I didn't think of that first. It was one of the main problems when the new server came up. Glad to hear everything is working for you now.
 

Twotricks

Private
1 Badges
Jun 15, 2012
10
0
  • 500k Club
My password is also suddenly not working ?

I have been in beta for quite some time now ...

What is happening ?
 

Twotricks

Private
1 Badges
Jun 15, 2012
10
0
  • 500k Club
Ok. I didnt transfer the account to the new server.

Now that I did, all is fine.

Thanks
 
Jun 15, 2012
19
0
Still can't login to the new forum properly. I did the account transfer and it said it worked, but now it won't accept my password. There is no option to reset password either if you can't login, so now I can't get into the forums or the game itself.
 

unmerged(376826)

General
Demi Moderator
1 Badges
Sep 12, 2011
2.032
0
  • Sword of the Stars
Are you typing in your user name exactly as it appears? It is a case sensitive field.
 
Jun 15, 2012
19
0
Omg, I just tried capitalizing the first letter in my username and it took!!!!
Wow, I never see case-sensitive username fields.
Thank you so much! You helped me a lot!!:laugh:
 
Last edited: