• Crusader Kings III Available Now!

    The realm rejoices as Paradox Interactive announces the launch of Crusader Kings III, the latest entry in the publisher’s grand strategy role-playing game franchise. Advisors may now jockey for positions of influence and adversaries should save their schemes for another day, because on this day Crusader Kings III can be purchased on Steam, the Paradox Store, and other major online retailers.


    Real Strategy Requires Cunning

Mariko

Recruit
Nov 4, 2017
1
0
At the start of the game, if I throw my weapon to save Heodan, trying to equip any further weapons in the now empty slot results in them being immediately unequipped. If I let him die instead, weapons can be changed about as normal, but of course I'm now down a party member.
 

Ivar83

Recruit
Jan 6, 2018
1
0
I have this same issue, at some point it let me re equip my weapons, but now that I'm in Gilded Vale, it has happened again, this is a deal breaker for me, it's really annoying not being able to re equip weapons in an RPG, or having to reset the game every time I want to change equipment. Please fix this, I bought this yesterday thinking it'd be fun, and it hasn't been because of this bug.
 

Mprov80

Recruit
Feb 24, 2018
1
0
I encountered this bug too a couple of days ago on my first play. If I unequipped my original weapon for any reason, the game would refuse to let me re-equip it or any other weapons or shields. Nothing would stick in any of the weapon slots.

Was pretty devastated. Can’t play an RPG without being able to change weapons. Ridiculous.

So I decided to try a few things out, and I have some important info to share.

The cutscene where you throw your weapon to save Heodan is NOT the trigger for the bug. It also occurs in the Encampment, at the very start of the game.

First, I deleted all my buggy save files to start afresh. I did not reinstall the software. Started a new game on Normal, with a default male human fighter, all default settings. As soon as the game gave me control of him, I tried unequipping and re-equipping his stuff. He started with a sword and shield. It all worked fine. No problems.

So I went a bit further, threw my sword, then attempted to equip a spare weapon in the cave. Fine. No bug!

Great! So I made a new game with my proper roleplaying character. Set up all her features/attributes, etc carefully, the way I wanted them. Went into inventory at the first opportunity. Unequipped her sword and tried re-equipping it. NOPE. Hit the bug. Could not equip any weapons.

She was also a fighter character. But started with a two-handed Estoc.

So the bug is to do with your starting equipment. The Culture option in Character Creation is what determines this. My character was a FIGHTER from OLD VAILIA. This particular combination triggers the bug. I tried a couple of other fighter combinations with different cultures and they were fine.

I don’t know if there are other class/culture combinations that trigger the bug, I didn’t try every possible variation, but FIGHTER + OLD VAILIA definitely is bugged.

Please, devs could you fix this. It’s extremely disheartening to encounter this as a new player, it leaves a horrible first impression. It’s a fantastic game, but at least one class/culture combination is practically unplayable.
 

Voodoomoocow

Recruit
39 Badges
Jun 20, 2019
1
0
  • Age of Wonders
  • Crusader Kings II: Way of Life
  • Cities: Skylines - After Dark
  • Crusader Kings II: Conclave
  • Cities: Skylines - Snowfall
  • Cities: Skylines - Natural Disasters
  • Cities: Skylines - Mass Transit
  • Surviving Mars
  • Age of Wonders III
  • Age of Wonders: Shadow Magic
  • Cities: Skylines Deluxe Edition
  • Age of Wonders II
  • Cities: Skylines - Green Cities
  • Cities: Skylines - Parklife Pre-Order
  • Cities: Skylines - Parklife
  • Shadowrun Returns
  • Shadowrun: Dragonfall
  • Shadowrun: Hong Kong
  • Cities: Skylines Industries
  • Cities: Skylines - Campus
  • Impire
  • Crusader Kings II: Legacy of Rome
  • Crusader Kings II: The Old Gods
  • Crusader Kings II: Rajas of India
  • Crusader Kings II: The Republic
  • Crusader Kings II: Sons of Abraham
  • Crusader Kings II: Sunset Invasion
  • Crusader Kings II: Sword of Islam
  • Hearts of Iron III
  • Crusader Kings II
  • Knights of Pen and Paper +1 Edition
  • Magicka
  • Sengoku
  • Ship Simulator Extremes
  • Teleglitch: Die More Edition
  • Victoria 2
  • War of the Roses
  • Cities: Skylines
It is now more than 2 years after original poster AND THIS BUG STILL EXISTS. I'm leaving this here because it is the first result when i googled. I just bought the game and just threw my sword and now cant equip anything. After reading the poster above me's experiment i went back and made a new character, similar to mine but different starting weapons and immediately tried to change weapons after Odema finished talking.

F.MoonGodlike/Priest/Living Lands has the bug. Two handed weapon
F.MoonGodlike/Priest/Archipelago has the bug. Sword and shield.

I'll try one more time and then I am returning it. I really want to roleplay a female godlike priest and i'm not wavering on that.