Possible Memory Leak

  • Crusader Kings II Expansion Subscription

    Subscribe to the CK II Expansion and enjoy unlimited access to 13 major expansions and more!


  • Paradox Midsummer Sale has arrived! Up to 75% off!

    Enjoy some sun and song this Midsummer, but when the sun goes down, the fun doesn't have to stop! Paradox has a festive sale on plenty of games to keep your summer nights going!


    June 18th - June 30th
  • Crusader Kings III Available Now!

    The realm rejoices as Paradox Interactive announces the launch of Crusader Kings III, the latest entry in the publisher’s grand strategy role-playing game franchise. Advisors may now jockey for positions of influence and adversaries should save their schemes for another day, because on this day Crusader Kings III can be purchased on Steam, the Paradox Store, and other major online retailers.


    Real Strategy Requires Cunning

unmerged(85297)

Recruit
Oct 9, 2007
3
0
Hello there :)

I seem to have 2 issues with Tarr Chronicles so far.The first one seems to be some sort of memory leak. I am using a G-15 Keyboard with LCD where vital information like FPS is displayed on, by Rivatuner (via Plugin).

While playing the game, I noticed, that whenever I start the game clean and load a mission, I have around 65-90FPS, depending on the scenery / action. However, that seems to change every time the game has to load something (e.g. Part II or III of a mission). Soon after, my system cannot score more than 40 frames per second, followed by another loading screen to e.g. Part III of a mission, leaving me with only 20-25FPS - no matter if there's a fight going on or just free flight on my own (without any other objects but the "space" on screen). These low fps also remain in the "hangar", where you see the parked ships. Going there, just after starting the game, I usually have far over 100 frames. - Again, it seems, the more time in the game passes (while it's running), the more loading screens have been executed, the lesser fps I get on my rig. Permanently, unless I restart the game, which pushes everything back to "normal speed".

If I exit the game and just reload the part of a mission I have been playing on, I am back to full fps again (65-90).

Another, but rather smaller issue (yet annoying), is a black screen I sometimes face, when starting Tarr Chronicles. The intro movies are playing fine - all but the last, the story one. That already just gives me sound, but no visible picture / movie. After hitting ESC, the menu usually should show up, which it does (i can hear the menu clicking sounds when I try to "hit" something blindly, with my mouse or keys) - but I just don't see anything else but a black screen.

A restart of the game solves that. Sometimes it loads correctly the first time, sometimes I need 2 tries.

Anyway - Here's my system specs :

- OS : Windows XP Professional 32Bit /w SP2
- Mainboard : Asus M2N-SLI Deluxe (Bios 1102)
- CPU : AMD Athlon64 X2 5600+
- Memory : Corsair Twin2x1024-6400c4 (2 GB DualChannel Kit)
- GFX Card (Driver) : NVidia GeForce (Leadtek) 8800 GTS 320MB (ForceWare 163.71)
- Using 4xFSAA + 8xAF (Forced via Driver)

I have my system overclocked - yet it doesn't matter if I run stock speeds or the "tuned" ones (I already tested that). The problem remains. As for the "memory leaking" part - this has also been found in a comment on gamersgate already (by users who bought the game online).

Just wanted to forward these "issues" I encountered so far. If you can think of anything that I might have done wrong, to cause these problems myself, please let me know here :)

Thanks in advance
Sony

P.S: Should the problem not be on my side - I also had the known "Memory bug" of the 8800 series cards in mind, which especially often happens on the 320 MB models. The bug fills the Vram with useless content till it overflows. In some games it was patched by developers, plus NVidia is constatly trying to fully eliminate it with an upcoming driver release.
 
Last edited:

unmerged(85297)

Recruit
Oct 9, 2007
3
0
Can you Paradoxers confirm or correct this ? :) (or is this perhaps an andressed issue coming along "fixed" with the patch the devs are workin on ?) :)
 
Last edited:

Killer

Second Lieutenant
6 Badges
Sep 12, 2001
149
10
  • Europa Universalis IV
  • Semper Fi
  • Victoria 2
  • 500k Club
  • Hearts of Iron IV Sign-up
  • Stellaris Sign-up
I have the same problem. For a while the game runs perfectly and then it turns into a slideshow (and even crashes).

But I have not yet encountered the black screen you mentioned.

My config is as follows:

Gigabyte K8NF9 Ultra MB
Athlon XP64 3200+
2x512MB RAM Kingston
nVidia GeForce 7900GT TOP
internal soundcard
MS Windows XP SP1 OS
 

unmerged(56137)

Colonel
Apr 22, 2006
904
0
I've got the exact same problems, the leak problem is really quite annoying. Also instead of a black screen I get the last ingame screen before the movie. So I can see my ship stranded in mid-space after the mission has been completed with the movie audio playing in the background, then the next mission briefing audio starts playing. I have to manually exit the game using the task manager and restart it again because video never comes back and is stuck on this one screen.

Another problem is also the game sometimes gives me a black screen at the menu when starting up after playing all the intro movies, I noticed that if I cancel them all pretty early this usually happens.
 

Flori

a stalker...
43 Badges
Aug 12, 2004
1.317
0
  • Crusader Kings II: Monks and Mystics
  • Europa Universalis III: Collection
  • Europa Universalis IV: El Dorado
  • Crusader Kings II: Way of Life
  • Europa Universalis IV: Common Sense
  • Crusader Kings II: Horse Lords
  • Europa Universalis IV: Cossacks
  • Crusader Kings II: Conclave
  • Europa Universalis IV: Mare Nostrum
  • Crusader Kings II: Reapers Due
  • Europa Universalis IV: Rights of Man
  • 500k Club
  • Europa Universalis IV: Mandate of Heaven
  • Europa Universalis IV: Third Rome
  • Europa Universalis IV: Cradle of Civilization
  • Crusader Kings II: Jade Dragon
  • Europa Universalis IV: Rule Britannia
  • Europa Universalis IV: Dharma
  • Europa Universalis IV: Golden Century
  • Crusader Kings III
  • Crusader Kings III: Royal Edition
  • Europa Universalis 4: Emperor
  • Divine Wind
  • Crusader Kings II: Charlemagne
  • Crusader Kings II: Legacy of Rome
  • Crusader Kings II: The Old Gods
  • Crusader Kings II: The Republic
  • Crusader Kings II: Sons of Abraham
  • Crusader Kings II: Sunset Invasion
  • Crusader Kings II: Sword of Islam
  • Diplomacy
  • Europa Universalis III
  • Europa Universalis III Complete
  • Crusader Kings II
  • Europa Universalis IV
  • Europa Universalis IV: Art of War
  • Europa Universalis IV: Conquest of Paradise
  • Europa Universalis IV: Wealth of Nations
  • Europa Universalis III Complete
  • Majesty 2 Collection
  • Europa Universalis III Complete
  • Europa Universalis IV: Res Publica
  • Warlock: Master of the Arcane
I will ask the developers to take a look at that as well. Thank you guys for the information.
 

unmerged(85297)

Recruit
Oct 9, 2007
3
0
M&M said:
Another problem is also the game sometimes gives me a black screen at the menu when starting up after playing all the intro movies, I noticed that if I cancel them all pretty early this usually happens.

That is the black screen I am talking about. Exactly the same symptoms.
 

unmerged(56137)

Colonel
Apr 22, 2006
904
0
well, you could try to let the intro movies at least appear on the screen first before cancelling them. That "seems" to have fixed it for me, I only tried it a few times but I've never had the black screen in any of those attempts.