• We have updated our Community Code of Conduct. Please read through the new rules for the forum that are an integral part of Paradox Interactive’s User Agreement.

Muir_of_Astora

Private
10 Badges
May 4, 2018
16
2
  • Crusader Kings II: Sword of Islam
  • War of the Roses
  • Crusader Kings II: Way of Life
  • Crusader Kings II: Horse Lords
  • Stellaris
  • Crusader Kings II: Monks and Mystics
  • Crusader Kings III
  • Crusader Kings II
  • Crusader Kings II: The Old Gods
  • Pillars of Eternity
I am continuing to have issues in the beta branch with being able to play multiplayer. Both my partner and I are having the same issue and are on the same internet connection.

We have 30mbps through Spectrum, cable.

When attempting to join each other, no matter which one of us is hosting, we can often get into the game together but within a few minutes it will say the other player has disconnected and upon returning to the main menu, it shows that we have been disconnected from Paradox Plaza via the icon over Join Game and Host Game.

I'll attach both of our multiplayer logs below. If there are any other logs that would be helpful, please let me know. I love this series, but have been largely unable to play CK3 because I always have played it with my brother, partner, and other friends.

The most frustrating thing is that I had zero issues on launch, but it suddenly became an issue.
 

Attachments

  • Gee Multiplayer Log.log
    118,3 KB · Views: 0
  • multiplayer.log
    176 KB · Views: 0
  • 1Like
Reactions:

BigPapaKasten

Recruit
1 Badges
Nov 22, 2020
6
0
  • Victoria 3 Sign Up
Ive contacted Paradox Support multiple times, the response has always been the same. Keep waiting, Ive been waiting for almost as long as the games been out. Frankly, without being to play one of the main components of the game Ive lost interest. And if they ever do fix it, which I doubt. With how unacceptably long its taken, and how little has been said about it from Paradox. I don't think ill regain that interest. And I pray they don't require you to log into a paradox account for Vic 3 multiplayer. Im guessing that has to do something with this issue, because I have been playing eu4 multiplayer fine with friends for the past while.
 

Muir_of_Astora

Private
10 Badges
May 4, 2018
16
2
  • Crusader Kings II: Sword of Islam
  • War of the Roses
  • Crusader Kings II: Way of Life
  • Crusader Kings II: Horse Lords
  • Stellaris
  • Crusader Kings II: Monks and Mystics
  • Crusader Kings III
  • Crusader Kings II
  • Crusader Kings II: The Old Gods
  • Pillars of Eternity
Ive contacted Paradox Support multiple times, the response has always been the same. Keep waiting, Ive been waiting for almost as long as the games been out. Frankly, without being to play one of the main components of the game Ive lost interest. And if they ever do fix it, which I doubt. With how unacceptably long its taken, and how little has been said about it from Paradox. I don't think ill regain that interest. And I pray they don't require you to log into a paradox account for Vic 3 multiplayer. Im guessing that has to do something with this issue, because I have been playing eu4 multiplayer fine with friends for the past while.
Hey! I actually got my multiplayer to work today with my partner who had been having the same issues I described in the original post. What I had to do is disable my IPv6 on my network adapter, I manged to find another thread that suggested it as a fix. I'll link it below. You may have already found that and tried, but since it worked for me I wanted to give you a heads up, I hope it works for you too.


"
Disable IPv6
- Close CK3
- Go to Control Panel > View Network status and tasks > Change adapter settings (left side)
- Find your Hamachi Connection and Disable it
- Find your Internet connection adapter (for me, it was WiFi)
- Right click your internet adapter and select properties
- Scroll down to find "Internet Protocol Version 6 (TCP/IPv6) and uncheck the box
- Select Ok
- Start up CK3 and should work.
"
 
  • 1
Reactions: