Official Magicka Status Report (Jan 26th)

  • We have updated our Community Code of Conduct. Please read through the new rules for the forum that are an integral part of Paradox Interactive’s User Agreement.
Jan 23, 2011
1
0
In hopes that some dev will read it:
I'm having trouble in the lobby room:
Despite the usual trying to connect errors (simply fail to connect or hard lock the entire computer or simply leaves the client), I've found myself an amusing bug: sometimes when I select a room and try to connect, I'll go to a completely different room, that I may or may not have entered before.
Besides sending me to a different room, when I get back to the lobby, the game just keeps reconnecting into the room BY ITSELF. I can go to the start screen (the first open page of the book), and it'll continue to do so. The only solution I've found is to restart the game.

-----
More amusing bugs:
While online, playing in the Tutorial, I actually drowned myself in the first stream of water (just before the 2 power generators and after the first power generated door). When the other player also crossed the stream, he got stuck in the drowning animation for at least 2 levels (on my client, not sure about his side).

During the airship battle (against the first ship full of goblins), I entered the enemy ship and didnt leave when it moved far from our ship. I think it is intended to consider myself dead at this moment, but that isnt the issue; my friend, who was on board of our ship, died for some reason, and we got the Defeated screen. However, nothing else happened. Our empty airship kept moving forward, until we decided to manually disconnect.

----

Not sure if this is a bug or a new intended mechanic, but during online play I was getting wet even when wearing a personal shield.


That's all I can think of at the moment! I love the game, just hope you guys can fix the issues.
 

Baleur

Captain
34 Badges
Mar 16, 2008
323
118
  • Cities in Motion 2
  • Stellaris
  • Pillars of Eternity
  • Age of Wonders III
  • Victoria 2: A House Divided
  • Cities in Motion
  • Sword of the Stars II
  • Magicka
  • Lost Empire - Immortals
  • King Arthur II
  • Heir to the Throne
  • Hearts of Iron III Collection
  • Europa Universalis IV: Conquest of Paradise
  • Europa Universalis IV
  • Divine Wind
  • Europa Universalis III: Chronicles
  • Europa Universalis III
  • Crusader Kings II: Sunset Invasion
  • Crusader Kings II
  • Stellaris - Path to Destruction bundle
  • Cities: Skylines - Natural Disasters
  • Stellaris: Leviathans Story Pack
  • Stellaris: Digital Anniversary Edition
  • Hearts of Iron IV Sign-up
  • Prison Architect
  • Stellaris: Galaxy Edition
  • Stellaris: Galaxy Edition
  • Cities: Skylines - Snowfall
  • Cities: Skylines - After Dark
  • Europa Universalis IV: Pre-order
  • Crusader Kings II: Holy Knight (pre-order)
  • 500k Club
  • Victoria 2
  • Cities: Skylines
[*]Inexplicable poor performance on some high end machines

Yep got this on my GTS 450, latest whql drivers, asus xonar d2 latest drivers, core 2 duo e6600, 3gb ram, 32bit vista.
I actually think the demo ran fine, and before this very-latest-patch it ran fine, but since now it runs really sluggish, as if it runs on 10fps through syrup.
 

unmerged(256019)

Private
1 Badges
Jan 27, 2011
19
0
  • Magicka
I played the demo and loved it so I bought the game and couldn't wait to play with some friends. I even bought the game a second time and gifted it to a friend of mine but when we tried to play tonight it didn't work. We both got the Connecting... and then nothing problems. We tried direct IP and joining through Steam friends list, we also tried loading into random games and still the same problem.

Can we please get a dev response on acknowledging all the connection issues people are having and and reaffirm that you are in fact working on a fix? I already gifted the game once and if the MP would work will probably do it 2 more times. I got this game mostly for the multiplayer and well....my friend and I can't do anything. I would assume since other games like Alien Swarm and what not don't have these problems its an issue the game and not people's computers. I would just like to know what is being done about it and a timeframe for a fix.
 

unmerged(187551)

Recruit
6 Badges
Dec 30, 2009
4
0
  • Crusader Kings II
  • Europa Universalis III Complete
  • Divine Wind
  • Hearts of Iron III
  • Heir to the Throne
  • Magicka
Ok, now it won't even start. The game opens and closes instantly with this error log...

Version: 1.3.3.0
Thread: LoaderThread
System.ArgumentException: An entry with the same key already exists.
at System.ThrowHelper.ThrowArgumentException(ExceptionResource resource)
at System.Collections.Generic.SortedList`2.Add(TKey key, TValue value)
at Magicka.GameLogic.Profile.Add(Gamer iGamer)
at Magicka.GameLogic.Profile.Read()
at Magicka.Game.LoaderFunction()
 

unmerged(256180)

Recruit
1 Badges
Jan 27, 2011
1
0
  • Magicka
Ok, now it won't even start. The game opens and closes instantly with this error log...

Version: 1.3.3.0
Thread: LoaderThread
System.ArgumentException: An entry with the same key already exists.
at System.ThrowHelper.ThrowArgumentException(ExceptionResource resource)
at System.Collections.Generic.SortedList`2.Add(TKey key, TValue value)
at Magicka.GameLogic.Profile.Add(Gamer iGamer)
at Magicka.GameLogic.Profile.Read()
at Magicka.Game.LoaderFunction()

I got the same problem..
 

unmerged(256196)

Recruit
1 Badges
Jan 27, 2011
8
0
  • Magicka
Guys, I really like the game, and my only issues with it currently have been the inexplicable performance drops on high end pc-s, and the fact that sometimes the screen would shift from the normal image, to a violet or black screen, on and off, althought i have not played much since the last patch (will do soon), so they might have been solved. I did have time to see that the in-game performance seems to have improved, but the start menu still seems to have some problems