• We have updated our Community Code of Conduct. Please read through the new rules for the forum that are an integral part of Paradox Interactive’s User Agreement.

Skodkim

Second Lieutenant
42 Badges
Mar 6, 2012
138
29
  • Crusader Kings II
  • Europa Universalis IV: Rule Britannia
  • Tyranny: Archon Edition
  • Stellaris: Leviathans Story Pack
  • Stellaris - Path to Destruction bundle
  • Europa Universalis IV: Mandate of Heaven
  • Age of Wonders III
  • Europa Universalis IV: Cradle of Civilization
  • Stellaris: Humanoids Species Pack
  • Stellaris: Apocalypse
  • Stellaris: Digital Anniversary Edition
  • Stellaris: Distant Stars
  • Stellaris: Megacorp
  • Stellaris: Ancient Relics
  • Stellaris: Lithoids
  • Stellaris: Federations
  • Imperator: Rome - Magna Graecia
  • Crusader Kings III
  • Stellaris: Necroids
  • Stellaris: Nemesis
  • Stellaris
  • Europa Universalis IV: Mare Nostrum
  • Europa Universalis IV: Cossacks
  • Crusader Kings II: Horse Lords
  • Europa Universalis IV: Rights of Man
  • Europa Universalis IV: Common Sense
  • Pillars of Eternity
  • Crusader Kings II: Way of Life
  • Europa Universalis IV: El Dorado
  • Europa Universalis IV
  • Crusader Kings II: Legacy of Rome
  • Crusader Kings II: The Old Gods
  • Crusader Kings II: The Republic
  • Crusader Kings II: Sons of Abraham
  • Europa Universalis IV: Art of War
  • Europa Universalis IV: Conquest of Paradise
  • Imperator: Rome
  • Europa Universalis IV: Wealth of Nations
  • Europa Universalis IV: Call to arms event
  • Europa Universalis IV: Res Publica
  • Stellaris: Synthetic Dawn
  • Europa Universalis IV: Third Rome
Hi

I've been playing Stellaris for some years now. I recently formatted my SSD, installed Win11, Steam and Stellaris (among other things).

After this I'm not able to take screenshots with F11 anymore. The funny thing the screenshot folder is actually created ny the program but even though the message comes in game no file is placed in the folder.

I've disabled In-Game overlay in Steam AND made sure F11 was not set as the screenshot shortcut just to make sure.

I have also tried disabling my antivirus program (Bitdefender).

None of this has solved the issue and I would very much appreciate it if someone could help out here as I use the fuction a lot.

Thanks in advance!!

BR
Joakim
 
Last edited:
Is there a Documents/Paradox Interactive/Stellaris/screenshots/ folder at all?

Is that folder local or on OneDrive?

Does f12 work for a Steam screenshot?
 
Hi

Thanks for the answer!!

As written, the Documents/Paradox Interactive/Stellaris/screenshots/ is created by the game the first time I make a screen shot - but no file is placed inside it.

The folder is local - not onedrive.

Also made sure that there's an exception for c:\program files (x86)\steam\steam.exe in Bitdefender (and tried while it was entirely turned off).

I had sisabled Steeam overlay AND removed the shortcuts for Steem screenshots alltogether in an attempt to solve the problem. I did however just make a test where I enabled it again, made f12 the shortcut and made a new folder "Documents/Steem Screenshots". However no screenshots are placed in the folder using f12 either.

BR
Joakim
 
Also made sure that there's an exception for c:\program files (x86)\steam\steam.exe in Bitdefender (and tried while it was entirely turned off).
But it's not Steam doing it, it's this game. Is stellaris.exe also exempted there?
 
What if you make a new Windows user on this machine and log into it with that - does it still happen (or rather not happen)?
 
FYI, can confirm this issue. Screenshots broken for me as well. Game says it took a screenshot but none appears. I had entered a bug report for this a week or so ago. Note that I have NOT reformatted my drive recently and I am using Windows 10. The screenshots directory is there but is always empty. Note that Steam-based screenshots work, but it's a pain trying to find the folder they're in.
 
I see, I guess it must be a bug then. Please add to the referenced bug reports thread. Thanks!
 
This forum is called Tech Support. It has a sister forum called Bug Reports. Do you see that above?

If so, I'm suggesting you make a ne wthread in there to report this as an apparent bug.
 
Update.

I made it work by forcing the program to run in DX9 mode

I made a shortcut and applied "-DX9" to the link, i.e. "C:\Program Files (x86)\Steam\steamapps\common\Stellaris\stellaris.exe" -dx9

Issue for me is, that this shortcut bypasses the launcher so I'm not ablt to e.g. control mods (I use them normaly but have tested without).

Tried applying -DX9 to the laucher shortcut in my desktop, i.e. "steam://rungameid/281990 -DX9", but that doesn't work.

How to I use the launcher and still force the game to run in DX9 (or fix this otherwise)?
 
In your Steam Library right-click on this game and choose Properties. In the Launch Options line, paste this in there:

-dx9