• We have updated our Community Code of Conduct. Please read through the new rules for the forum that are an integral part of Paradox Interactive’s User Agreement.

Aardvark Bellay

Lord Wuffington of Grumpytown by the barks
21 Badges
Apr 5, 2001
15.598
3.069
  • Divine Wind
  • Stellaris Sign-up
  • Hearts of Iron IV Sign-up
  • Crusader Kings II: Horse Lords
  • Crusader Kings II: Holy Knight (pre-order)
  • 500k Club
  • Victoria 2: Heart of Darkness
  • Victoria 2: A House Divided
  • Victoria 2
  • Victoria: Revolutions
  • Heir to the Throne
  • Crusader Kings II
  • Europa Universalis III
  • Deus Vult
  • Crusader Kings II: Sword of Islam
  • Crusader Kings II: Sons of Abraham
  • Crusader Kings II: The Republic
  • Crusader Kings II: Rajas of India
  • Crusader Kings II: The Old Gods
  • Crusader Kings II: Legacy of Rome
  • Crusader Kings II: Charlemagne
No more shortcuts inside the Province tooltip (bottom right)

Credit: goes solely to Romulien
I just copied his description on how to.

Standard Vanilla CK2
smallProvinceShortcut.jpg


With mod:
smallNoshortcurtInProvinceTolltip.jpg


Versions and last update time:
The first one is old and for before patch 3.x . Still working , but not adapted.
The second is the updated one from 2022 ( 13.th dec '22) for the current 3.3.5.1 patch.

Direct download :
See attachments below

Steam Workshop (only old version) :
http://steamcommunity.com/sharedfiles/filedetails/?id=1095287184


If you had used the old version beforehand, it's better to first delete the old two files, mod file and folder
(if Steam Workshop variant then zip and *.mod file) in
Documents/Paradox Interactive/Crusader Kings 2 /mod
before moving the new file and folder into the "mod" folder, especially if you had used the Steam Workshop variant.
 

Attachments

  • No Shortcuts In Province Tooltip.7z
    471 bytes · Views: 102
  • 2022 NoShortcutsProvincetooltip.zip
    1,3 KB · Views: 0
Last edited:
I updated the mod.

Now all shortcuts in the province infos are gone.

The only difference to the pictures above is the info about defensive terrain :
"If a combat takes place here, the defender will get a defensive bonus"

I left this in, as i suppose some might want to keep this info.
I have no idea how to limit this, so it doesn't appear in all mapmode info boxes.

Additionaly i took out the bottom text in the trade info tooltip, as it widened that one a lot
and seperated the lines in the tooltip for the trade mapmode key, so that it's smaller.

I couldn't finda way to do something about the detailed, but huge opinion mapmode info box.

If anyone has questions or suggestions, leave them here.
 
Last edited:
I updated the mod.
Thank you very much.

I simply grabbed the CSV and swapped it out. The STEAM workshop doesn't work for me with this game. I think it is a Paradox loader issue. Thus, I used a tool to download my former STEAM subs and reformat them for a mod manager called JSGME which came out of Silent Hunter 3 modding and became a popular tool.

It works very nice. THANK YOU!!!
 
  • 1
Reactions:
Thank you very much.

I simply grabbed the CSV and swapped it out. The STEAM workshop doesn't work for me with this game. I think it is a Paradox loader issue. Thus, I used a tool to download my former STEAM subs and reformat them for a mod manager called JSGME which came out of Silent Hunter 3 modding and became a popular tool.

It works very nice. THANK YOU!!!

Interesting.
Steam Workshop is not working for me either, but the subbed mods dowload into Steam/userdata....and i then move them accodringly and add a *.mod file and make them work this way.

For info, though you likely know, you can use the mod as packed in the zip, but of course you can do load and use the mod however you want.
 
This originally worked for me with the problem you have, you want to try:

To fix the Steam Workshop:

- I already knew about the WORKSHOP\CONTENT directory,
but the entry 203770 is not created.

- A mod directory needs to be added in the user data
section.

- Set the global steam setting to sync games from the
cloud.

- In the settings.txt file. Set:

steam_rich_presence=yes

- Manage your mods via subscriptions.

- You must launch the game once to fetch them. And
a second time to enable them.

- If you wish to permanently remove any mods, then
just purge the mod directory.

I didn't know about the Paradox modding direct method. But I was familiar JSGME and how to download mods directly from the WORKSHOP. I am pretty sure it was the launcher which broke things, since there was not launcher previously.


JSGME is fine, since mods for CK2 are going to be very static. Thanks for the fixes!!!