• Crusader Kings III Available Now!

    The realm rejoices as Paradox Interactive announces the launch of Crusader Kings III, the latest entry in the publisher’s grand strategy role-playing game franchise. Advisors may now jockey for positions of influence and adversaries should save their schemes for another day, because on this day Crusader Kings III can be purchased on Steam, the Paradox Store, and other major online retailers.


    Real Strategy Requires Cunning

Doom032

Corporal
8 Badges
Mar 21, 2009
45
0
  • Crusader Kings II
  • Europa Universalis III Complete
  • Divine Wind
  • Heir to the Throne
  • Europa Universalis III Complete
  • Europa Universalis III Complete
  • Victoria 2
  • 500k Club
I've been looking to play this mod, and since the mod is finally compatible with the latest version of CK2, I downloaded and installed it yesterday. I used the zip, unzipped the ElderKings folder and the .mod file to ~/.paradoxinteractive/Crusader\ Kings\ II/mod, and created an empty ElderKings folder in ~/.paradoxinteractive/Crusader\ Kings\ II/.

First thing I noticed when I tried to start ck2(`./ck2 -mod="mod/ElderKings.mod"' ) was that it kept crashing on startup on a CFileException. As expected, error.log showed that a certain file couldn't be found. I looked for the file and found it existed, but with a different capitalization than given in the error. In Windows, case doesn't matter in file names. file.txt is the same as FILE.TXT, but on Unix these are both different files.

So I went to find and fix these errors by editing the files. These were the changes I've made so far:

interface/settlements.gfx - replaced all occurences of "hell" with "Hell"
interface/avatars.gfx - replaced all occurences of "_round_" with "_Round_"
renamed "gfx/models/attachments" to "gfx/models/Attachments"

These changes have got me past the first few of these errors, but then I got the error that a file called "gfx/models/Mapindicators/Eastern_Chancellor.xac" wasn't being found(looked for in avatars.gfx). I looked up the file in the mod files and couldn't find it, and I looked up the file in CK2's own files and couldn't find it either.

Is there another place that CK2 looks in to try to find game files where the mod expected to find it? Or am I missing a file or something? I'm kind of confused by this.

Interestingly there is a "Western_Chancellor.xac" file in CK2's Mapindicators folder, but no "Eastern_Chancellor.xac".
 

Akuthia

First Lieutenant
58 Badges
May 9, 2012
274
1
  • Crusader Kings II
  • Warlock 2: The Exiled
  • Hearts of Iron IV: Cadet
  • Crusader Kings II: Holy Fury
  • Hearts of Iron IV: Colonel
  • Crusader Kings II: Reapers Due
  • Europa Universalis IV: Rights of Man
  • Hearts of Iron IV: Expansion Pass
  • Hearts of Iron IV: Together for Victory
  • Crusader Kings II: Monks and Mystics
  • Cities: Skylines - Mass Transit
  • Europa Universalis IV: Mandate of Heaven
  • BATTLETECH
  • Surviving Mars
  • Hearts of Iron IV: Death or Dishonor
  • Europa Universalis IV: Golden Century
  • Cities: Skylines - Green Cities
  • Europa Universalis IV: Cradle of Civilization
  • Hearts of Iron IV: Expansion Pass
  • Europa Universalis IV: Rule Britannia
  • Cities: Skylines - Parklife Pre-Order
  • Cities: Skylines - Parklife
  • Shadowrun Returns
  • Shadowrun: Dragonfall
  • Cities: Skylines Industries
  • Mount & Blade: Warband
  • Age of Wonders: Planetfall
  • Europa Universalis IV: Art of War
  • Europa Universalis IV: Wealth of Nations
  • Age of Wonders: Planetfall Deluxe edition
  • Warlock: Master of the Arcane
  • 500k Club
  • Magicka: Wizard Wars Founder Wizard
  • Crusader Kings II: Way of Life
  • Prison Architect
  • Crusader Kings III
  • Europa Universalis IV: Common Sense
  • Cities: Skylines - After Dark
  • Europa Universalis IV: Cossacks
  • Crusader Kings II: Conclave
  • Cities: Skylines - Snowfall
  • Crusader Kings II: Charlemagne
  • Crusader Kings II: The Old Gods
  • Crusader Kings II: Rajas of India
  • Crusader Kings II: Sword of Islam
  • Majesty 2
  • Sword of the Stars
  • Cities: Skylines
  • Magicka 2
Strange, I just did a search on a windows machine, and I'm not finding a file in either location either, but I have no crashing problem...
 

Doom032

Corporal
8 Badges
Mar 21, 2009
45
0
  • Crusader Kings II
  • Europa Universalis III Complete
  • Divine Wind
  • Heir to the Throne
  • Europa Universalis III Complete
  • Europa Universalis III Complete
  • Victoria 2
  • 500k Club
Try to look for it in the LoR DLC file
Ah, Yes. I found it in dlc011.zip, but it looks like there's no capitalization problem here. gfx/models/Mapindicators/Eastern_Chancellor.xac in both the DLC file and in avatars.gfx. Makes me wonder why it can't find it.

Anyway I tempfixed it by basically doing this:
interface/avatars.gfx - replaced all occurences of "Mapindicators/Eastern_" with "Mapindicators/Western_"
interface/avatars.gfx - replaced all occurences of "Chancellor.xsm" with "Chancellor_Idle.xsm"

Which, to my surprise, allowed the game to start up without crashing immediately. I even played it just now for a few months and then came back to post this. Awesome!

If anyone else is trying to get this to work on Linux, this is step-by-step what I did to get it working(I mostly said this more verbosely in OP):
- Download the Elder Kings zip file
- Unzip ElderKings and ElderKings.mod to ~/.paradoxinteractive/Crusader\ Kings\ II/mod (create the folder if it doesn't exist)
- Unzip the Large Resolution Files folder to the ElderKings folder you just unzipped if relevant(see Installation_Instructions.txt)
- Create the folder ~/.paradoxinteractive/Crusader\ Kings\ II/ElderKings and leave it empty
- Rename the folder (Inside the mod/ElderKings folder) "gfx/models/attachments" to "gfx/models/Attachments"
- Search and replace the following terms in the following files(recommended to use a text editor with a search & replace function)
. - interface/settlements.gfx - replace all occurences of "hell" with "Hell"
. - interface/avatars.gfx - replace all occurences of "_round_" with "_Round_"

And if it still doesn't work because it can't find Eastern_Chancellor, use the hack I described above in this post.

error.log is still showing a lot of files not being found, but at least it starts up and works with that.
(Here's the current error.log: http://pastebin.com/xsevygBR )

Maybe if those capitalization issues are fixed by the mod devs it can work out of the box on Linux. :3
 

Jepaan

Sergeant
66 Badges
Dec 31, 2009
60
0
  • Crusader Kings II: Jade Dragon
  • Magicka 2
  • Pillars of Eternity
  • Crusader Kings II: Conclave
  • Age of Wonders III
  • Europa Universalis IV: El Dorado
  • Magicka: Wizard Wars Founder Wizard
  • Mount & Blade: Warband
  • Crusader Kings II: Way of Life
  • Europa Universalis IV: Common Sense
  • Crusader Kings II: Horse Lords
  • Europa Universalis IV: Cossacks
  • Crusader Kings II: Holy Fury
  • Europa Universalis IV: Mare Nostrum
  • Stellaris
  • Stellaris: Galaxy Edition
  • Stellaris Sign-up
  • Hearts of Iron IV: Cadet
  • Crusader Kings II: Reapers Due
  • Europa Universalis IV: Rights of Man
  • Stellaris: Digital Anniversary Edition
  • Stellaris: Leviathans Story Pack
  • Crusader Kings II: Monks and Mystics
  • Europa Universalis IV: Mandate of Heaven
  • Stellaris: Humanoids Species Pack
  • Stellaris: Ancient Relics
  • Stellaris: Lithoids
  • Prison Architect
  • Europa Universalis IV: Golden Century
  • Stellaris: Megacorp
  • Europa Universalis IV: Cradle of Civilization
  • Stellaris: Apocalypse
  • Europa Universalis IV: Rule Britannia
  • Europa Universalis III Complete
  • Stellaris: Distant Stars
  • Europa Universalis III Complete
  • Europa Universalis IV: Dharma
  • Victoria 2
  • 500k Club
  • Stellaris: Synthetic Dawn
  • Europa Universalis IV: Third Rome
  • Stellaris - Path to Destruction bundle
  • Stellaris: Galaxy Edition
  • Victoria 2: Heart of Darkness
  • Victoria 2: A House Divided
  • Europa Universalis III
  • Crusader Kings II: Sword of Islam
  • Crusader Kings II: Sunset Invasion
  • Crusader Kings II: Sons of Abraham
It is quite common for many mods to suffer from this. There is really no reason not to make sure the casing is correct, other than being to lazy to bother.
And it's not unique to Linux, you can configure Linux to ignore these mistakes if you so want, and I'm pretty sure you can configure Windows to not ignore them too.

Personally, I just fix whatever mistakes I find, doesn't take more than a couple of minutes anyway. For larger mods, I consider making a bug report too.
 

Illanair

Space Duck
77 Badges
Feb 28, 2011
6.325
610
  • Victoria 2
  • Knights of Pen and Paper +1 Edition
  • Leviathan: Warships
  • Magicka
  • March of the Eagles
  • Europa Universalis IV: Res Publica
  • Victoria: Revolutions
  • Sword of the Stars
  • Sword of the Stars II
  • The Showdown Effect
  • A Game of Dwarves
  • Victoria 2: A House Divided
  • Victoria 2: Heart of Darkness
  • Warlock 2: The Exiled
  • War of the Vikings
  • Stellaris - Path to Destruction bundle
  • Age of Wonders III
  • Stellaris
  • Stellaris: Galaxy Edition
  • Dungeonland
  • Crusader Kings II
  • Crusader Kings II: The Old Gods
  • Crusader Kings II: Legacy of Rome
  • Crusader Kings II: Rajas of India
  • Heir to the Throne
  • Crusader Kings II: The Republic
  • Crusader Kings II: Sons of Abraham
  • Crusader Kings II: Sunset Invasion
  • Crusader Kings II: Sword of Islam
  • Cities in Motion
  • Europa Universalis III
  • Europa Universalis III: Chronicles
  • Europa Universalis III Complete
  • Divine Wind
  • Europa Universalis IV: Conquest of Paradise
  • Europa Universalis IV: Wealth of Nations
  • Europa Universalis IV: Call to arms event
  • Pillars of Eternity
  • Magicka 2 - Signup Campaign
  • Warlock: Master of the Arcane
  • Cities: Skylines - Snowfall
  • Stellaris: Galaxy Edition
  • Victoria 2 Beta
  • Magicka: Wizard Wars Founder Wizard
  • Europa Universalis IV: Pre-order
  • 500k Club
  • War of the Roses
  • Crusader Kings III
  • Europa Universalis III Complete
The thing that confuses me is that these are references and strings in the executable, not filenames right? I really don't see why Linux itself would have any issues with mismatched lettercasing as long as it isn't happening in the file system. :confused:
 
Last edited:

Jepaan

Sergeant
66 Badges
Dec 31, 2009
60
0
  • Crusader Kings II: Jade Dragon
  • Magicka 2
  • Pillars of Eternity
  • Crusader Kings II: Conclave
  • Age of Wonders III
  • Europa Universalis IV: El Dorado
  • Magicka: Wizard Wars Founder Wizard
  • Mount & Blade: Warband
  • Crusader Kings II: Way of Life
  • Europa Universalis IV: Common Sense
  • Crusader Kings II: Horse Lords
  • Europa Universalis IV: Cossacks
  • Crusader Kings II: Holy Fury
  • Europa Universalis IV: Mare Nostrum
  • Stellaris
  • Stellaris: Galaxy Edition
  • Stellaris Sign-up
  • Hearts of Iron IV: Cadet
  • Crusader Kings II: Reapers Due
  • Europa Universalis IV: Rights of Man
  • Stellaris: Digital Anniversary Edition
  • Stellaris: Leviathans Story Pack
  • Crusader Kings II: Monks and Mystics
  • Europa Universalis IV: Mandate of Heaven
  • Stellaris: Humanoids Species Pack
  • Stellaris: Ancient Relics
  • Stellaris: Lithoids
  • Prison Architect
  • Europa Universalis IV: Golden Century
  • Stellaris: Megacorp
  • Europa Universalis IV: Cradle of Civilization
  • Stellaris: Apocalypse
  • Europa Universalis IV: Rule Britannia
  • Europa Universalis III Complete
  • Stellaris: Distant Stars
  • Europa Universalis III Complete
  • Europa Universalis IV: Dharma
  • Victoria 2
  • 500k Club
  • Stellaris: Synthetic Dawn
  • Europa Universalis IV: Third Rome
  • Stellaris - Path to Destruction bundle
  • Stellaris: Galaxy Edition
  • Victoria 2: Heart of Darkness
  • Victoria 2: A House Divided
  • Europa Universalis III
  • Crusader Kings II: Sword of Islam
  • Crusader Kings II: Sunset Invasion
  • Crusader Kings II: Sons of Abraham
A typical example is like this:
interface/settlements.gfx contains a reference to the file "gfx\models\Settlements\Western\Western_Port.xac".
However, the file distributed in the mod is called Western_port.xac instead. This will typically be an issue in Linux, because the two names technically aren't identical due to the casing, and most Linux systems will therefore report that the file does not not exist.
So for the developers, the issue is easily fixed by always using the same naming convention and sticking to it.
 

Korbah

Ratel
131 Badges
Mar 3, 2011
4.755
1.243
  • Crusader Kings II: Holy Knight (pre-order)
  • Cities: Skylines - Snowfall
  • Cities: Skylines - Natural Disasters
  • Cities: Skylines - Campus
  • Age of Wonders: Planetfall
  • Age of Wonders: Planetfall Deluxe edition
  • Crusader Kings III
  • Crusader Kings III: Royal Edition
A typical example is like this:
interface/settlements.gfx contains a reference to the file "gfx\models\Settlements\Western\Western_Port.xac".
However, the file distributed in the mod is called Western_port.xac instead. This will typically be an issue in Linux, because the two names technically aren't identical due to the casing, and most Linux systems will therefore report that the file does not not exist.
So for the developers, the issue is easily fixed by always using the same naming convention and sticking to it.
Post the fixed files, and I will add them in. If you don't want to contribute the fixed files, do not call us lazy. :p
 

Jepaan

Sergeant
66 Badges
Dec 31, 2009
60
0
  • Crusader Kings II: Jade Dragon
  • Magicka 2
  • Pillars of Eternity
  • Crusader Kings II: Conclave
  • Age of Wonders III
  • Europa Universalis IV: El Dorado
  • Magicka: Wizard Wars Founder Wizard
  • Mount & Blade: Warband
  • Crusader Kings II: Way of Life
  • Europa Universalis IV: Common Sense
  • Crusader Kings II: Horse Lords
  • Europa Universalis IV: Cossacks
  • Crusader Kings II: Holy Fury
  • Europa Universalis IV: Mare Nostrum
  • Stellaris
  • Stellaris: Galaxy Edition
  • Stellaris Sign-up
  • Hearts of Iron IV: Cadet
  • Crusader Kings II: Reapers Due
  • Europa Universalis IV: Rights of Man
  • Stellaris: Digital Anniversary Edition
  • Stellaris: Leviathans Story Pack
  • Crusader Kings II: Monks and Mystics
  • Europa Universalis IV: Mandate of Heaven
  • Stellaris: Humanoids Species Pack
  • Stellaris: Ancient Relics
  • Stellaris: Lithoids
  • Prison Architect
  • Europa Universalis IV: Golden Century
  • Stellaris: Megacorp
  • Europa Universalis IV: Cradle of Civilization
  • Stellaris: Apocalypse
  • Europa Universalis IV: Rule Britannia
  • Europa Universalis III Complete
  • Stellaris: Distant Stars
  • Europa Universalis III Complete
  • Europa Universalis IV: Dharma
  • Victoria 2
  • 500k Club
  • Stellaris: Synthetic Dawn
  • Europa Universalis IV: Third Rome
  • Stellaris - Path to Destruction bundle
  • Stellaris: Galaxy Edition
  • Victoria 2: Heart of Darkness
  • Victoria 2: A House Divided
  • Europa Universalis III
  • Crusader Kings II: Sword of Islam
  • Crusader Kings II: Sunset Invasion
  • Crusader Kings II: Sons of Abraham
Fair enough, this fixes all crashes due to using hellenic instead of Hellenic and round instead of Round.
interface/settlements.gfx : http://pastebin.com/79Qr45tw
interface/avatars.gfx: http://pastebin.com/8ZQWt6n7

There's still a lot of errors reported, can't say if this is also true in Windows, but the game doesn't crash with these fixes and seems to be running fine.

Remaining errors:
Code:
[texturehandler.cpp:181]: Couldn't find texture file: gfx/models/Settlements/Moorish/Mooris_city_02_diffuse.tga.
[emfxactortype.cpp:630]: Bad texture: gfx/models/Settlements/Moorish/Mooris_city_02_diffuse.tga in EMFX actor file gfx/models/Settlements/Moorish/Mooris_City_02.xac
[emfxactortype.cpp:630]: Bad texture: gfx/models/Settlements/Moorish/Mooris_city_02_diffuse.tga in EMFX actor file gfx/models/Settlements/Moorish/Mooris_City_02.xac
[texturehandler.cpp:181]: Couldn't find texture file: gfx//characters//bosmer_male//bosmer_male_neck.dds.
[spritetype.cpp:370]: Error initialising texture: gfx//characters//bosmer_male//bosmer_male_neck.dds for spritetype GFX_bosmer_male_neck
[texturehandler.cpp:181]: Couldn't find texture file: gfx//characters//bosmer_male//bosmer_male_base.dds.
[spritetype.cpp:370]: Error initialising texture: gfx//characters//bosmer_male//bosmer_male_base.dds for spritetype GFX_bosmer_male_base
[texturehandler.cpp:181]: Couldn't find texture file: gfx//characters//maormer_male//maormer_male_beard_behind.dds.
[spritetype.cpp:370]: Error initialising texture: gfx//characters//maormer_male//maormer_male_beard_behind.dds for spritetype GFX_maormer_male_beard_behind
[spritetype.cpp:378]: Texture gfx\\interface\\minimap_area.tga have forbidden compression, have you tried DXT3?
[texturehandler.cpp:181]: Couldn't find texture file: gfx//characters//falmer_male//falmer_male_nose.dds.
[spritetype.cpp:370]: Error initialising texture: gfx//characters//falmer_male//falmer_male_nose.dds for spritetype GFX_falmer_male_nose
[texturehandler.cpp:181]: Couldn't find texture file: gfx//characters//dunmer_male//dunmer_male_neck.dds.
[spritetype.cpp:370]: Error initialising texture: gfx//characters//dunmer_male//dunmer_male_neck.dds for spritetype GFX_dunmer_male_neck
[texturehandler.cpp:181]: Couldn't find texture file: gfx//characters//maormer_male//maormer_male_eyes2.dds.
[spritetype.cpp:370]: Error initialising texture: gfx//characters//maormer_male//maormer_male_eyes2.dds for spritetype GFX_maormer_male_eyes2
[texturehandler.cpp:181]: Couldn't find texture file: gfx//interface//minimap_bg_esm.tga.
[spritetype.cpp:370]: Error initialising texture: gfx\\interface\\minimap_bg_esm.tga for spritetype GFX_minimap_bg
[texturehandler.cpp:181]: Couldn't find texture file: gfx//characters//dwemer_male//dwemer_beard_behind.dds.
[spritetype.cpp:370]: Error initialising texture: gfx//characters//dwemer_male//dwemer_beard_behind.dds for spritetype GFX_dwemer_male_beard_behind
[texturehandler.cpp:181]: Couldn't find texture file: gfx//characters//altmer_male//altmer_male_clothes_behind.dds.
[spritetype.cpp:370]: Error initialising texture: gfx//characters//altmer_male//altmer_male_clothes_behind.dds for spritetype GFX_altmer_male_clothes_behind
[texturehandler.cpp:181]: Couldn't find texture file: gfx//characters//falmer_male//falmer_beard_behind.dds.
[spritetype.cpp:370]: Error initialising texture: gfx//characters//falmer_male//falmer_beard_behind.dds for spritetype GFX_falmer_male_beard_behind
[texturehandler.cpp:181]: Couldn't find texture file: gfx//characters//dunmer_female//dunmer_female_eyes2.dds.
[spritetype.cpp:370]: Error initialising texture: gfx//characters//dunmer_female//dunmer_female_eyes2.dds for spritetype GFX_dunmer_female_eyes2
[texturehandler.cpp:181]: Couldn't find texture file: gfx//characters//dunmer_female//dunmer_female_base.dds.
[spritetype.cpp:370]: Error initialising texture: gfx//characters//dunmer_female//dunmer_female_base.dds for spritetype GFX_dunmer_female_base
[texturehandler.cpp:181]: Couldn't find texture file: gfx//characters//falmer_male//falmer_male_eyes.dds.
[spritetype.cpp:370]: Error initialising texture: gfx//characters//falmer_male//falmer_male_eyes.dds for spritetype GFX_falmer_male_eyes
[texturehandler.cpp:181]: Couldn't find texture file: gfx//characters//maormer_female//maormer_female_paint.dds.
[spritetype.cpp:370]: Error initialising texture: gfx//characters//maormer_female//maormer_female_paint.dds for spritetype GFX_maormer_female_paint
[texturehandler.cpp:181]: Couldn't find texture file: gfx//characters//maormer_male//maormer_male_beard.dds.
[spritetype.cpp:370]: Error initialising texture: gfx//characters//maormer_male//maormer_male_beard.dds for spritetype GFX_maormer_male_beard
[texturehandler.cpp:181]: Couldn't find texture file: gfx//interface//minimap_bg_big_esm.tga.
[spritetype.cpp:370]: Error initialising texture: gfx\\interface\\minimap_bg_big_esm.tga for spritetype GFX_minimap_bg_big
[texturehandler.cpp:181]: Couldn't find texture file: gfx//characters//altmer_male//altmer_male_clothes.dds.
[spritetype.cpp:370]: Error initialising texture: gfx//characters//altmer_male//altmer_male_clothes.dds for spritetype GFX_altmer_male_clothes
[texturehandler.cpp:181]: Couldn't find texture file: gfx//characters//falmer_male//falmer_male_chin.dds.
[spritetype.cpp:370]: Error initialising texture: gfx//characters//falmer_male//falmer_male_chin.dds for spritetype GFX_falmer_male_chin
[texturehandler.cpp:181]: Couldn't find texture file: gfx//characters//falmer_male//falmer_male_ear.dds.
[spritetype.cpp:370]: Error initialising texture: gfx//characters//falmer_male//falmer_male_ear.dds for spritetype GFX_falmer_male_ear
[texturehandler.cpp:181]: Couldn't find texture file: gfx//characters//altmer_male//altmer_beard_behind.dds.
[spritetype.cpp:370]: Error initialising texture: gfx//characters//altmer_male//altmer_beard_behind.dds for spritetype GFX_altmer_male_beard_behind
[texturehandler.cpp:181]: Couldn't find texture file: gfx//characters//falmer_male//falmer_male_beard.dds.
[spritetype.cpp:370]: Error initialising texture: gfx//characters//falmer_male//falmer_male_beard.dds for spritetype GFX_falmer_male_beard
[texturehandler.cpp:181]: Couldn't find texture file: gfx//characters//falmer_male//falmer_male_hair.dds.
[spritetype.cpp:370]: Error initialising texture: gfx//characters//falmer_male//falmer_male_hair.dds for spritetype GFX_falmer_male_hair
[texturehandler.cpp:181]: Couldn't find texture file: gfx//characters//altmer_male//altmer_male_clothes_infront.dds.
[spritetype.cpp:370]: Error initialising texture: gfx//characters//altmer_male//altmer_male_clothes_infront.dds for spritetype GFX_altmer_male_clothes_infront
[texturehandler.cpp:181]: Couldn't find texture file: gfx//characters//falmer_male//falmer_male_hair_behind.dds.
[spritetype.cpp:370]: Error initialising texture: gfx//characters//falmer_male//falmer_male_hair_behind.dds for spritetype GFX_falmer_male_hair_behind
[texturehandler.cpp:181]: Couldn't find texture file: gfx//characters//bosmer_male//bosmer_beard_behind.dds.
[spritetype.cpp:370]: Error initialising texture: gfx//characters//bosmer_male//bosmer_beard_behind.dds for spritetype GFX_bosmer_male_beard_behind
[texturehandler.cpp:181]: Couldn't find texture file: gfx//characters//falmer_male//falmer_male_mouth.dds.
[spritetype.cpp:370]: Error initialising texture: gfx//characters//falmer_male//falmer_male_mouth.dds for spritetype GFX_falmer_male_mouth
[id.cpp:83]: Failed to create id 7500003 40. Already exists in game.

*Edit*

Alright, the game doesn't really run fine. After a couple of month ingame, it crashes with the following message:
Code:
ck2: /var/lib/jenkins/jenkins-tmp/jenkins-tmp/workspace/CK2-Release-Linux/external_libs/EMotionFX/API/Source/ActorManager.cpp:116: EMotionFX::ActorInstance *EMotionFX::ActorManager::CreateInstance(EMotionFX::Actor *, const TransformData::ECloneFlags, bool): Assertion `1==0' failed.
Afbrudt (SIGABRT) (core dumped)
Not totally sure if this is related with the other issues, will investigate further when I have the time.
 
Last edited: