iPad: Light on top of Locked Door prevents either from being Dismantled/Dumped


Sep 13, 2017
As subject line says. I have a door that has a light on top of it. While the door was open I selected it and cycled it to be always locked. Later on when I went to remove the door, I found I can only select the light on top of it. I select the light and then try both Dismantle or Dump and workers will approach it, stand near it for a second, then walk away. I've tried destroying everything surrounding the door, but no luck. I've read on PC that you can hit Tab to cycle through objects on the same space, so I tried attaching a bluetooth keyboard to my iPad and hitting the Tab key, but no luck there either.
Upvote 0


The Full Monty Python
116 Badges
Jun 29, 2001
  • Leviathan: Warships
  • Europa Universalis IV: Wealth of Nations
  • Europa Universalis IV: Call to arms event
  • For The Glory
  • Gettysburg
  • Hearts of Iron III
  • Heir to the Throne
  • Impire
  • Europa Universalis III Complete
  • King Arthur II
  • Knights of Pen and Paper +1 Edition
  • Lead and Gold
  • Legio
  • Europa Universalis IV: Conquest of Paradise
  • The Kings Crusade
  • Lost Empire - Immortals
  • Magicka
  • Majesty 2 Collection
  • March of the Eagles
  • Europa Universalis III Complete
  • Naval War: Arctic Circle
  • Pirates of Black Cove
  • Europa Universalis IV: Res Publica
  • Europa Universalis: Rome
  • Rome Gold
  • Stellaris: Necroids
  • Crusader Kings II: Sunset Invasion
  • Ancient Space
  • Arsenal of Democracy
  • Hearts of Iron II: Armageddon
  • Cities in Motion
  • Cities in Motion 2
  • Crusader Kings II
  • Crusader Kings II: Charlemagne
  • Crusader Kings II: Legacy of Rome
  • Crusader Kings II: The Old Gods
  • Crusader Kings II: Rajas of India
  • Crusader Kings II: The Republic
  • Crusader Kings II: Sons of Abraham
  • A Game of Dwarves
  • Crusader Kings II: Sword of Islam
  • Commander: Conquest of the Americas
  • Darkest Hour
  • Dungeonland
  • East India Company Collection
  • Europa Universalis III
  • Europa Universalis III: Chronicles
  • Europa Universalis III Complete
  • Divine Wind
  • Europa Universalis IV
I'm sorry about that! This is a logged bug which has not been fixed yet. I expect that the tab functionality you mention will have to be achieved some other way, such as multiple clicking.


Sep 13, 2017
Heh, well I was coming to write another bug about a dead body that is never taken away, except I finally found it, under the locked shut door that's under the light.

So now my prison is haunted, the herse is just sitting out front there, waiting for an update. ;-)


Sep 13, 2017
So, is there a way to edit the save file on the iPad? I've got 18 dead bodies queued up now after a couple of riots, and I have a concern that when this bug gets addressed all those bodies are going to get flushed out at once and will trigger a lose condition. So if I can unlock the door via an editor of some kind I'd prefer to do that now.