• We have updated our Community Code of Conduct. Please read through the new rules for the forum that are an integral part of Paradox Interactive’s User Agreement.
Showing developer posts only. Show all posts in this thread.
Team members:
Retired / Inactive
Last edited:
  • 7
  • 5
  • 3
  • 1Like
HIP --> EU4 conversion instructions
Simply convert your save in the same way as you would for vanilla.

Conversion with SWMH enabled is not supported.
Last edited:
  • 13
Just a minor Bug in actual Version , somehow installer will install NBRT+ before SWMH, causes some missing textures and textures.
New Version is up in a few Mins !!
Meneth will inform you ASAP here ... sorry guys :)
Note that the issue only exist if you use both SWMH and NBRT+. If you don't, then there's no point redownloading once the file's been replaced (should happen within 5 mins).
It looks like you have to unzip the downloaded archive directly in your MOD folder or you don't get the files in the correct location. At least that's what happened to me.
Much like all mods.
I'll stick a note in the install instructions for the next version though, and in the install instructions in this thread.
Man the mac install instructions are really confusing. Any plans on fixing that in the future? Whenever i add another folder with the same name it removes the entire folder. Im pretty sure its not supposed to work that way.
Unless you're on OS X or Linux, you really should just use the installer. That's why it is there.
It is near impossible to simplify the manual installation much.
Just a minor Bug in actual Version , somehow installer will install NBRT+ before SWMH, causes some missing textures and trees.
New Version is up in a few Mins !!
Meneth will inform you ASAP here ... sorry guys :)
It has now been resolved.
Using Win7. Try to run .exe, but cmd prompt appears for a split second, disappears and then nothing happens.

Is it just for 64-bit systems? I can't open the installer on my 32-bit :/
Did the two of you make sure to unzip the python33.dll? If you don't have Python 3.3 installed that's needed to run the installer.
I hate to be that guy, but I think something is wrong here.

I picked the following modules:
-AKOpack Armories
-AKOpack Interface
-VIET traits
-VIET events
-VIET immersion

This should give me the same setup I was using before HIP, but I notice the merged on_actions file is missing all the VIET stuff like events from Generic_Events_1.txt


Also, on a second run of HIP.exe the Historical Immersion Project folder was deleted, but a new one was not created until the third run.
Running the installer more than once will mess things up, since it moves the modules (as copying would be incredibly slow in comparison).

As to the on_actions issue, that seems to be Cybr's fault due to how he set up the on_actions :p
I'll get it fixed.

If you use Sunset Invasion with this will the Aztecs always show up, or has that been modified similar to the way it is in CK2+?
It is like in vanilla.
installed python 3.3 to make sure. still not working. do i have to be running in an english locale?
Very strange. Even if the functions somehow failed, it should be stopping to ask for input the moment you open it.
It shouldn't matter what you're running it on as long as it is Windows.
I have a same issue. +i installed python 3.3.3 already.
It is coded in 3.3.6, though that really shouldn't cause any issues.
Getting an error whenever I try to use the installer provided, here is a snapshot of the error. Similarly to others - it opens and instantly closes.


win7 64bit is the only information I can imagine as relevant atm
Could you try using this installer? http://www.mediafire.com/download/ri86qdppyfinyv8/HIP.exe

What if you want to change your settings? Do you need to manually remove the mod folder and extract the archive again to start over?
Yes. The alternative is installation taking an order of magnitude or two longer to finish.
That worked fine, filesize is also identical to my manually "compiled" one. Also, I noticed that Latin Empire is called "Romania" with the english PB/SWMH names. Is this really intentional?
Yeah, the issue was French diacritics clashing with the encoding set for your command line. The .7z has been replaced once more, fixing to my knowledge every issue reported so far.

No clue about the Latin Empire, but Aasmul and co. probably know.
Still not able to solve the ARKO coat of arms issue.. I wonder if perhaps using ARKO as a separate install path might be better for those having issues? The dynasty coat of arms are quite frankly all a mess.
What exact combination of modules are you using?
Congratulations on this mod!

I have a little problem. No matter which combination of modules I try, some rulers have blank/black portraits. Is there a solution to that? I have all dlc enabled if that means anything.
I imagine you're using VIET Immersion?
To my knowledge that issue is caused by you lacking some of the portrait DLC. The old VIET download used to include a fix, but we forgot to include that in this download (and we'll have to find a decent way to do so).

ARKO, PB, VIET, NBRT+. The main issue is that coat of arms for most of the landed dynasties are just either blank or incorrectly placed. Not sure if that's due to an integration issue, or what it could be.
Which VIET Modules?
Most likely VIET Immersion is the culprit since that has a dynasties file of its own.

Are the sub modules of PB (like No Ahistorical Empires) compatible with the rest of the mods in this version of HIP?
All of them should work with ARKO, NBRT+, SWMH, and VIET Events.
Some of them might break together with VIET Immersion; I'm not sure.

Note that right now the Module Pack isn't actually actively supported, but it will likely be revived for one of the next few releases of HIP once we figure out the best way to do so.
Could I ask for a few clarifications, please? :)

1) In the "readme" for those who can't do .exe files, does the manual installation need to be done after the automatic installation instructions listed, or instead of it?
2) As per step 1, where do the modules folder and HIP.mod need extracting to? Into a Historical Immersion Project folder in /CKII/mods created for the purpose, or somewhere else?
1) Instead of. I'll clarify that in the next release
2) Your mod folder. I'll clarify that in the next release
I notice that the custom interface causes an issue with the outliner where a scrollbar covers the right end of any text. Is this the correct spot to report that or should it be moved somewhere else?
The ARKO thread would be the best place to report that, as that's where Arko is the most likely to see it.
Will 00_dynasties.txt have to be deleted in BOTH PB_VIETImmersion and regular VIET_immersion, I wonder?
PB_VIET_Immersion will be enough. Right now the two are mutually exclusive.

Next version the installer should take care of the issue.
I can't open it no matter what I do, tried everything mentioned in the thread. Anyone on a 32-system who's been able to get it to work?
Did you make sure to redownload it? The version fixing the installer problems some users were experienced was uploaded 50 minutes ago.

If it still doesn't work, is there any sort of error message?
Slight fix to the ARKO version of dynasties - dynasty #1029055 should be

"1029055 = {
culture = maghreb_arabic

Was uncapitalised and not formatted properly.
Report that in the ARKO thread, please.
Also, in bookmarks, perhaps place Stamford Bridge back ahead of William the Conqueror? Just strange on the senses at first.
That's a Project Balance change. It is due to it being the primary balancing point of PB, so I want to encourage users to play it.
The error message on a Win7 32bit system says that "the application is incompatible with the OS you are using". On a 64bit system it runs just fine.
Ah. That's a shame.
Not really sure there's anything I could do about it seeing as I'm on a 64-bit system.
Luckily 32-bit systems are dying out.
If anyone is still getting a command line very briefly flashing up (rather than the 32-bits error described above) when running the installer, could you try this installer? http://www.mediafire.com/download/ri86qdppyfinyv8/HIP.exe
It won't fix the issue, but it should actually display whatever error message you're getting so that you can post it here so we might fix it.