• We have updated our Community Code of Conduct. Please read through the new rules for the forum that are an integral part of Paradox Interactive’s User Agreement.

hiskra

Private
21 Badges
Jan 8, 2021
21
68
  • Crusader Kings III: Royal Edition
  • Victoria 3 Sign Up
  • Crusader Kings II
  • Cities: Skylines
  • Europa Universalis IV
EDIT: I think I've posted this in the wrong room. Sorry.

I've made a proper thread at the Bug Report sub. To any authorized user, you may delete this thread if necessary.





Hello everyone.

My game is having CTD when opening a map (the "choose anyone on the map" button). I have attached the latest log files here. Yesterday I managed to get into a MP session ( meaning I can get into the maps and such), which ended only after repeated CTD after 2-5 minutes of playing. The game was using 2 graphical mods btw. Today I started without any mods and got these (finally reproducible) CTDs. Sometimes it even crashes the Steam WebHelper service or even Steam itself, which is weird.

Things I've done:
  • Verified file integrity
  • Updated the video card driver
  • Launched the game without mods
Do you have any suggestions on what to do? Please help.

Longer complains:

In the past Quill update, the game also crashed a lot without the crash reporter even showing up, randomly. The randomness of it made me really hesitant to make a report about it, practically unreproducible because sometimes the CTDs happen after 15 minutes or 6 hours. Reading the logfile doesn't help, and the last log is always complaints about "something missing" or "duplicate entries" or something like that, which I don't really know how to start basic debugging on my own. The latest update makes it real and finally produces a reproducible CTD.

Vic3, after the update, also suffers the same fate, but with, I think, a fundamentally different form of CTD (in the past I was able to launch and play a short game), but I think that's irrelevant to my problem and the forum.
 

Attachments

  • debug.log
    256,9 KB · Views: 0
  • dedicated_server.log
    140 bytes · Views: 0
  • error.log
    1,9 KB · Views: 0
  • game.log
    64,5 KB · Views: 0
Last edited:
Right click on ck3.exe , properties, compatibility. Tick "disable fullScreen optimisations" untick every other box in that dialog, Apply and exit.
Then in the launcher Game Settings menu, select fullScreen display mode, Vsync off, cap refresh rate at 60.


If those don't help:
DXDIAG is a program you run from the Windows search box on the task bar. After running it will open a window and start collecting info with a progress bar in the lower-left corner. When it completes click the 'save all information' button and save it to a file then attach that file here.

Please attach here your Documents/Paradox Interactive/CK3/pdx_settings.txt .
From your Documents/Paradox Interactive/CK3/logs/ folder, attach here system.log , error.log , exceptions.log
 
Right click on ck3.exe , properties, compatibility. Tick "disable fullScreen optimisations" untick every other box in that dialog, Apply and exit.
Then in the launcher Game Settings menu, select fullScreen display mode, Vsync off, cap refresh rate at 60.


If those don't help:
DXDIAG is a program you run from the Windows search box on the task bar. After running it will open a window and start collecting info with a progress bar in the lower-left corner. When it completes click the 'save all information' button and save it to a file then attach that file here.

Please attach here your Documents/Paradox Interactive/CK3/pdx_settings.txt .
From your Documents/Paradox Interactive/CK3/logs/ folder, attach here system.log , error.log , exceptions.log
Hey. Thanks for your response and apologies for taking so long to reply.

I ran the game 3 times today (all without mods). Disabling fullscreen optimization caused the game to crash on the first loading screen. To be sure, I decided to run it again and same result, but now with Steam WebHelper crashing and forcing Steam to restart. Then I decided to re-enable fullscreen optimization and I was able to see the main menu and finally crashed at the "select someone on the map" loading screen (the original problem) but this time causing the Steam program to be killed (not running in the background).

Other games in my library are running fine, and I haven't seen any game crashes that managed to shut down Steam itself like this. This is really interesting.

I have attached the logs I grabbed after the crashes: the one with fullscreen optimization disabled (1) and enabled (2) also with dxdiag file. There is no exception.log file produced and the system.log has no content in it (so I am unable to upload it).

Please help. I've been edging to play until LoP drops, but even today I can't play it.
 

Attachments

  • 1 error.log
    7,1 KB · Views: 0
  • 1 pdx_settings.txt
    5,6 KB · Views: 0
  • 2 error.log
    2,5 KB · Views: 0
  • 2 pdx_settings.txt
    5,6 KB · Views: 0
  • DxDiag.txt
    138 KB · Views: 0
Just launched the game after clean reinstall and deleting the whole Documents/Paradox. The issue still presists even after nuking it all.

I don't really have to reinstall windows, right? Buying a new hardware is not a choice atm.
 
"setting_framerate_cap"={
version=0
value="off"
}
Did you set the cap to 60, as I suggested? If not please try that.

Either way what fps do you see in the game now?


The other issue is you are critically short of free space on both your drives. In particular there is not enough space on C: for Windows to do any more swapping out. Windows' boot drive should have at least 10% free space. In your situation I'd see if you can get like 50gb free, then up your paging file max size to say 32gb

At the very least unload all other apps before starting this game.
 
Did you set the cap to 60, as I suggested? If not please try that.

Either way what fps do you see in the game now?


The other issue is you are critically short of free space on both your drives. In particular there is not enough space on C: for Windows to do any more swapping out. Windows' boot drive should have at least 10% free space. In your situation I'd see if you can get like 50gb free, then up your paging file max size to say 32gb

At the very least unload all other apps before starting this game.
Hello.

Yes. Thanks, I admit I totally missed that. The game is able to run this time, though I'm encountering the same mid-game crashes back as the pre-LoP version of the game. But it's still playable. Anyway, thanks for your assistance.

By the way, my potato laptop of course can't run the game beyond 30 FPS on my 1080 screen, it's ok for me. I also applied the same treatment to Vicky and it runs too (with mid-game crashes, sadly)! Maybe I need to make a separate thread on these crashes, but I'm not sure.

Any idea why this treatment happened to be necessary? I've been running both games maybe since release, but this is the first time I've had to fiddle with the compatibility settings.
 
You could be running low on available memory. Did you expand the paging file as I suggested?

Also unload every other app you can before starting the game.
 
The low memory maybe the actual culprit of all of these crashes.

I just remembered I manually decreased the pagefile months ago. Setting it back I notice no crashes after >4 hrs play. Thank you thank you thank you!