• Crusader Kings III Available Now!

    The realm rejoices as Paradox Interactive announces the launch of Crusader Kings III, the latest entry in the publisher’s grand strategy role-playing game franchise. Advisors may now jockey for positions of influence and adversaries should save their schemes for another day, because on this day Crusader Kings III can be purchased on Steam, the Paradox Store, and other major online retailers.


    Real Strategy Requires Cunning

This thread is more than 5 months old.

It is very likely that it does not need any further discussion and thus bumping it serves no purpose. If you feel it is necessary to make a new reply, you can still do so though.

Pwnschlager

Recruit
2 Badges
Mar 15, 2016
1
0
  • Teleglitch: Die More Edition
  • Prison Architect
As a long time Unix user I have no idea what I'm doing but here are my specs:

Windows 7
CPU: i7 6820HQ
GPU: nVidia Quadro M2000M
8GB DDR4 RAM

So, I tried donloading the game on Steam and tried to open it...
Without even seeing a window pop up,Windows tells me that the "program has stopped working",
as per my developer istincts i instantly click on "debug"...
It open Visual Studio and tells me : Unhandled exception at 0x0120103D in Teleglitch.exe: 0xC0000005: Access violation reading location 0x00000000.
Obviously VS cant find the symbol which tells it where the source code is, so i open disassembly..

it seems to be stuck at the highlighted address.

01201034 mov dword ptr [ebp-8],eax
01201037 mov dword ptr [ebp-4],eax
0120103A mov eax,dword ptr [ebp+8]
>>> 0120103D movsx ecx,byte ptr [eax]
01201040 test ecx,ecx
01201042 jne 0120104D
01201044 mov dword ptr [ebp-4],0

Also, here is my stderr:

Initializing Lua...
------------------------------------------------------
INFO: Detected controllers: 0
Connecting to steam...OK
INFO: Steam cloud file "discoveries0" read successful. Bytes read:235
INFO: Steam cloud file "discoveries1" read successful. Bytes read:118
INFO: Steam cloud file "discoveries2" read successful. Bytes read:1292
INFO: Steam cloud file "discoveries4" read successful. Bytes read:45
Initializing graphics...
------------------------------------------------------
ERROR:Invalid window


Any help? Ideas? Fixes?

Thanks!
-mks


Edit: the log shows:
'Teleglitch.exe' (Win32): Loaded 'C:\Program Files (x86)\Steam\steamapps\common\TeleglitchDME\lua52.dll'. Cannot find or open the PDB file.

Dont know if thats important but here ya go...
 
Last edited: