TheDragonlord

Recruit
31 Badges
Jul 20, 2016
3
0
  • Europa Universalis IV
  • Crusader Kings II: Jade Dragon
  • Europa Universalis IV: Cradle of Civilization
  • Europa Universalis IV: Third Rome
  • Crusader Kings Complete
  • Crusader Kings II: Monks and Mystics
  • Crusader Kings II: Reapers Due
  • Crusader Kings II: Conclave
  • Crusader Kings II: Horse Lords
  • Crusader Kings II: Way of Life
  • Victoria 2
  • Victoria: Revolutions
  • Rome: Vae Victis
  • Victoria 2: Heart of Darkness
  • Victoria 2: A House Divided
  • Sengoku
  • Rome Gold
  • Arsenal of Democracy
  • March of the Eagles
  • For The Glory
  • Dungeonland
  • Darkest Hour
  • Crusader Kings II: Sword of Islam
  • Crusader Kings II: Sunset Invasion
  • Crusader Kings II: Sons of Abraham
  • Crusader Kings II: The Republic
  • Crusader Kings II: Rajas of India
  • Crusader Kings II: The Old Gods
  • Crusader Kings II: Legacy of Rome
  • Crusader Kings II: Charlemagne
  • Crusader Kings II
I recently bought the game (yes the first one) and when I try to run it I can see the Paradox logo but then the game freezes and I have to close it. is there anything that can be done or is it just too old to work with Windows 10?
 

Verrucosus

Sergeant
8 Badges
Apr 28, 2007
93
25
  • Crusader Kings II
  • Europa Universalis III
  • Europa Universalis IV
  • Hearts of Iron III
  • Europa Universalis: Rome
  • Victoria 2
  • 500k Club
  • Europa Universalis III: Collection
I don't have Windows 10 yet, but was able to get it to run on Windows 8.1. The paradox intro is actually a short movie ("paradox.avi") contained in the avi sub-folder. Just to make sure it's not that movie or the proper intro ("euintro.avi") that causes the freeze, you could try renaming those files and see what happens. Sorry for not having any better ideas, but I suspect in this well-hidden corner of the forum any response is welcome. Good luck!
 

TheDragonlord

Recruit
31 Badges
Jul 20, 2016
3
0
  • Europa Universalis IV
  • Crusader Kings II: Jade Dragon
  • Europa Universalis IV: Cradle of Civilization
  • Europa Universalis IV: Third Rome
  • Crusader Kings Complete
  • Crusader Kings II: Monks and Mystics
  • Crusader Kings II: Reapers Due
  • Crusader Kings II: Conclave
  • Crusader Kings II: Horse Lords
  • Crusader Kings II: Way of Life
  • Victoria 2
  • Victoria: Revolutions
  • Rome: Vae Victis
  • Victoria 2: Heart of Darkness
  • Victoria 2: A House Divided
  • Sengoku
  • Rome Gold
  • Arsenal of Democracy
  • March of the Eagles
  • For The Glory
  • Dungeonland
  • Darkest Hour
  • Crusader Kings II: Sword of Islam
  • Crusader Kings II: Sunset Invasion
  • Crusader Kings II: Sons of Abraham
  • Crusader Kings II: The Republic
  • Crusader Kings II: Rajas of India
  • Crusader Kings II: The Old Gods
  • Crusader Kings II: Legacy of Rome
  • Crusader Kings II: Charlemagne
  • Crusader Kings II
I don't have Windows 10 yet, but was able to get it to run on Windows 8.1. The paradox intro is actually a short movie ("paradox.avi") contained in the avi sub-folder. Just to make sure it's not that movie or the proper intro ("euintro.avi") that causes the freeze, you could try renaming those files and see what happens. Sorry for not having any better ideas, but I suspect in this well-hidden corner of the forum any response is welcome. Good luck!
Thank you for replying :). Messing with paradox.avi breaks everything more where as messing with euintro.avi does nothing, but more importantly paradox.avi actually seems to work with it's normal name, euintro is just completely broken as it won't even let itself be played back any "mediaplayer programs" to my computer (whereas paradox will).
 

Verrucosus

Sergeant
8 Badges
Apr 28, 2007
93
25
  • Crusader Kings II
  • Europa Universalis III
  • Europa Universalis IV
  • Hearts of Iron III
  • Europa Universalis: Rome
  • Victoria 2
  • 500k Club
  • Europa Universalis III: Collection
Hmmm, that's interesting. Maybe some incompatibility between Windows 10 and the euintro file causes the freeze.

Since paradox.avi seems to work alright, you could try this:
(1) rename euintro.avi into something else (euintro.org)
(2) make a copy of paradox.avi
(3) rename that copy "euintro.avi"
(4) try running the game to see whether it starts now after showing the paradox logo twice

Good luck!

PS: Next time I play EU1, I won't skip the intro. :) Who knows whether I can watch it again once I have to use Windows 10?
 

Karterii

Recruit
Aug 14, 2016
2
0
Hiya!
No worries, this is a common issue, and there's an easy fix which worked for me.
Here's a link to a thread on the Steam Community forums regarding another game, X-Wing. Both Europa Universalis 1 and this game suffer from the same problem.

Simply put, go there, download the files the user linked to, and just copy/paste them into your EU1 folder (the one with the .exe in it!). It'll override the old files, and will let you play the game on Windows 10. Again, worked for me!

... Well, at least for the most part it did. You won't be enjoying any sound or music from the game. Not the biggest problem since you could just put on the soundtrack on YouTube while playing, but it's still a bit of a shame.

Hope that'll help and make the game work for you :)
 

Army Vet

Sergeant
2 Badges
Feb 28, 2018
90
0
  • BATTLETECH - Beta Backer
  • BATTLETECH - Backer
Hiya!
No worries, this is a common issue, and there's an easy fix which worked for me.
Here's a link to a thread on the Steam Community forums regarding another game, X-Wing. Both Europa Universalis 1 and this game suffer from the same problem.

Simply put, go there, download the files the user linked to, and just copy/paste them into your EU1 folder (the one with the .exe in it!). It'll override the old files, and will let you play the game on Windows 10. Again, worked for me!

... Well, at least for the most part it did. You won't be enjoying any sound or music from the game. Not the biggest problem since you could just put on the soundtrack on YouTube while playing, but it's still a bit of a shame.

Hope that'll help and make the game work for you :)

When I first tried running EU 1, I got nothing showing though it did appear in Task Manage and said it was using Very High Power.
So far I tried once to do the ZIP download and extract those files.
After that tried running, this time got a black screen but something about a missing or corrupted file.
I notice the link is for a X-Wing thread so I guess some stuff listed there cannot be done.
Is all I need the 4 files from the ZIP or is there something else.

(Yes, I figured better use a thread appropriate to the subject according to internet etiquette than open a new one.)
 

Yodaloo

Private
3 Badges
Sep 1, 2018
10
51
  • Stellaris
  • Stellaris - Path to Destruction bundle
  • Stellaris: Synthetic Dawn
When I first tried running EU 1, I got nothing showing though it did appear in Task Manage and said it was using Very High Power.
So far I tried once to do the ZIP download and extract those files.
After that tried running, this time got a black screen but something about a missing or corrupted file.
I notice the link is for a X-Wing thread so I guess some stuff listed there cannot be done.
Is all I need the 4 files from the ZIP or is there something else.

(Yes, I figured better use a thread appropriate to the subject according to internet etiquette than open a new one.)

I'm having a similar issue.