• We have updated our Community Code of Conduct. Please read through the new rules for the forum that are an integral part of Paradox Interactive’s User Agreement.
reinstalled the game after deleting it, updated AGCEEP. Tried the register fix mentioned in the other topic, however i still keep getting the same crash. Only thing that does work is the menu and the tutorial... all else fails.

i also added save games folders :(
 
I am now having this same problem. I was playing for a few days with no problem, then it randomly started crashing on start-up again. Occasionally it gets past start up but then crashes when I click on a saved game or try to change mods (AGCEEP->Vanilla). By manually changing the resolution in the settings file to 800x600 I was able to successfully load a saved game one time, but after trying other resolutions it again isn't working and haven't gotten 800x600 to work again either.
 
I am now having this same problem. I was playing for a few days with no problem, then it randomly started crashing on start-up again. Occasionally it gets past start up but then crashes when I click on a saved game or try to change mods (AGCEEP->Vanilla). By manually changing the resolution in the settings file to 800x600 I was able to successfully load a saved game one time, but after trying other resolutions it again isn't working and haven't gotten 800x600 to work again either.

Which operating system do you use? If Windows 10 do you already run the game in compatibility mode?
In which folder did you install the game? If C:\Programs... you do already always start the game with administrator rights?
Steamversion of FtG or not?
You already checked the TechFAQ for the common causes of problems?
 
oh boy, i tried the register fix again and it WORKS!!!!!!!

One question remains, i have the steam version of FTG and its updated to 1.2 version. However, i dont know what happens with AGCEEP. Do i need to update that manualy
 
thank you mate, by the way. Is this the version i should be installing?:
Version 1.59b4_hotfix (for 1.3 public beta)
Download here: http://www.mediafire.com/?62a96daxldb4bce
Alternate link: http://www.gamefront.com/files/22994774/AGCEEP159b4_hotfix.zip

Version 1.59b4 (1.2) is now available for FTG.

Download here: http://www.gamefront.com/files/21823682/AGCEEP159b4_rar
Alternate link: http://www.mediafire.com/?ijx27agomh6gk5p

It is written right in the text you quoted: IF you are using the 1.2 (last official patch of the game) THEN you use the second one. IF you are using the 1.3 public beta patch THEN you are using the first one.

Be aware that using the 1.3 beta patch is good if you play the vanilla game (lots of bugfixes) but bad if you play mods (because changes in the database mean that all mods that work with version 1.2 of the game have problems with version 1.3 of the game until the mod is updated by it’s author too).
 
Hi guys, I had dropped temporality from the forum to do other stuff and then pretty much permanently because I think I'm having this same problem (game crashes on scenario selection, but can enter the tutorials), but now that I see other people have this same problem I might be able to return to FtG!
Now here's the thing: I tried the regedit fix others have mentioned (entering $ DWM8And16BitMitigation WINXPSP3 Layer_ForceDirectDrawEmulation), but now I'm getting the following messages right after running the executable:

Failed to create attached surface
Failed to create primary surface code 2005532108
Fatal error: could not initialize video (it also says that if I'm running in a window, which is not the case, the OS must be in 16-bit mode. Later on I tried doing both of those things but the game justs gets stuck will initializing, showing me the edges of the window but nothing else)

Right after that I get a ctd

Some other information:
I'm using WIndows 7
I have tried uninstalling and reinstalling the game several times and I have changed folders (from program files (x86) to program files)
I'm using the gamersgate copy
The game crashed both with the unpatched game and with the beta (plus 1.1 and 1.2)
With the beta (and without the fix), the checksum is WBOJ
As far as I can tell moddebug doesn't yield anything important. With and without the fix it's just lines about opening vanilla files
The screen resolution I'm using is 1920x1080 (fullscreen)
Darkest Hour isn't working for me either

That's pretty much it. I hope it is of some use.
 
...
Now here's the thing: I tried the regedit fix others have mentioned (entering $ DWM8And16BitMitigation WINXPSP3 Layer_ForceDirectDrawEmulation), but now I'm getting the following messages right after running the executable:

Such fixes are dangerous as changing it wrong can cause additional issues and should be the last option to use when everything else has failed and not be the first to try.

Failed to create attached surface
Failed to create primary surface code 2005532108
Fatal error: could not initialize video (it also says that if I'm running in a window, which is not the case, the OS must be in 16-bit mode. Later on I tried doing both of those things but the game justs gets stuck will initializing, showing me the edges of the window but nothing else)

Right after that I get a ctd

Some other information:
I'm using WIndows 7
I have tried uninstalling and reinstalling the game several times and I have changed folders (from program files (x86) to program files)
I'm using the gamersgate copy
The game crashed both with the unpatched game and with the beta (plus 1.1 and 1.2)
With the beta (and without the fix), the checksum is WBOJ
As far as I can tell moddebug doesn't yield anything important. With and without the fix it's just lines about opening vanilla files
The screen resolution I'm using is 1920x1080 (fullscreen)
Darkest Hour isn't working for me either

That's pretty much it. I hope it is of some use.

Start by going over the techsupport FAQ for newer operating systems first
https://forum.paradoxplaza.com/forum/index.php?threads/tech-support-faq.444126/
e.g. not installing in /program files OR if you do having to run it with administrator rights
 
Last edited:
Hey conjurer. I used the fix because to me this problem is too specific to be unrelated to the one other people are having. Moreover I don't really what else I could do, since there was nothing I changed in the game from the last time it worked to the time it didn't, nor did I change the OS or video card or anything like that.

As for the faq, thanks for the link, but it doesn't seem to have anything related to my problem.
 
Hey conjurer. I used the fix because to me this problem is too specific to be unrelated to the one other people are having. Moreover I don't really what else I could do, since there was nothing I changed in the game from the last time it worked to the time it didn't, nor did I change the OS or video card or anything like that.

As for the faq, thanks for the link, but it doesn't seem to have anything related to my problem.

It should. You mentioned yourself that you installed the game in a folder changed"...from program files (x86) to program files...".
And the FAQ tells us for Windows Vista or Windows 7 NOT to install the game in e.g. C:\Program Files\... because if that folder is used the game needs administrator rights to run. The common way to prevent that is to install somewhere else, e.g. my FtG folder is: "G:\Paradox\For the Glory".

When you write that you use Windows 7 then what operating system do you mean? Windows 7 32 bit or 64bit?

When you wrote that you installed and deinstalled the game several times, did you actually completely deinstall it each time? (e.g. not just delete the folder it was installed in but deinstall to remove all remnants in the registry?).

Have you tried a smaller resolution to see if the game runs in that without that problem? e.g. my settings.txt is
Code:
moddebug = yes
runbackground = no
gui = {
   language = "l_English"
}
graphics = {
   size = {
       x = 1280
       y = 1024
   }
   fullscreen = yes
}
music = yes
lastmod = {
   dir = ""
   style = {
       shields = "enhanced"
       font = "glory"
       interface = "Glory"
       colorscales = "glory"
   }
}
 
Firstly, my WIndows 7 is 64 bit, and I have been using administrator rights the whole time. That aside, this time I uninstalled the game the way you said and installed it outside the program files folder, however I'm still getting the same ctd without the fix and the same problems initializing the game when I use it. I'm also using the resolution you suggested.

EDIT: I haven't patched the game yet
 
Firstly, my WIndows 7 is 64 bit, and I have been using administrator rights the whole time. That aside, this time I uninstalled the game the way you said and installed it outside the program files folder, however I'm still getting the same ctd without the fix and the same problems initializing the game when I use it. I'm also using the resolution you suggested.

EDIT: I haven't patched the game yet

FtG was created for 32bit systems. So if you are using Windows 7 64 bit you should enable the Windows 7 compatibility mode, e.g. for Windows XP
https://support.microsoft.com/en-us/help/15078/windows-make-older-programs-compatible

And when you install obsolete versions of the game then you should first update them to the last official patch (1.2)
https://forum.paradoxplaza.com/forum/index.php?threads/1-2-is-now-out.489887/
so that if problems arise, we know that they are not caused by using older versions.
 
Well, I was already using Windows XP compatibility settings, and updating the game to 1.2 hasn't changed anything. The game still crashed right after I click on a scenario.
 
Well, I was already using Windows XP compatibility settings, and updating the game to 1.2 hasn't changed anything. The game still crashed right after I click on a scenario.

O.k. then the next possible problems:

Did you check that savegamefolders were created for the vanilla game and AGCEEP as in the Techsupport FAQ from your Gamersgate installation?
e.g. for me that would be
G:\Paradox\For the Glory\Scenarios\Save Games
and
G:\Paradox\For the Glory\Mods\AGCEEP\Scenarios\Save Games
If the game failed to create them you have to add them manually as the game would crash when trying to save or the game tries to create an autosave.

In case you are trying to run the game in windowed mode did you remember to change the display to 16bit colours or to set the compatibility mode to 16bit colours?

If the game crashes when starting a game with AGCEEP: As the FtG 1.2 patch does not include an update for AGCEEP you have to download and update the mod manually
https://forum.paradoxplaza.com/forum/index.php?threads/version-1-59b4-is-up.509577/
 
None of those things is relevant to my predicament, unfortunately: There is a save games folder, I'm playing with a fullscreen setting and the crash is with vanilla. The confusing thing about the whole issue is that the worked just fine until some months ago, and I haven't anything important to the computer (and nothing at all to the game) since then.