Randomishness

Recruit
58 Badges
Feb 6, 2018
3
0
  • Crusader Kings II
  • Sword of the Stars
  • Sengoku
  • Crusader Kings II: The Republic
  • Crusader Kings II: Rajas of India
  • Crusader Kings II: The Old Gods
  • Crusader Kings II: Legacy of Rome
  • Stellaris: Megacorp
  • Cities: Skylines - Campus
  • Cities: Skylines Industries
  • Stellaris: Distant Stars
  • Cities: Skylines - Parklife
  • Stellaris: Apocalypse
  • Stellaris: Humanoids Species Pack
  • Hearts of Iron IV: Expansion Pass
  • Crusader Kings II: Jade Dragon
  • Cities: Skylines - Green Cities
  • Age of Wonders III
  • Crusader Kings II: Holy Fury
  • Imperator: Rome
  • Hearts of Iron IV: Expansion Pass
  • Crusader Kings II: Monks and Mystics
  • Stellaris: Ancient Relics
  • Age of Wonders: Planetfall
  • Age of Wonders: Planetfall Deluxe edition
  • Age of Wonders: Planetfall Premium edition
  • Age of Wonders: Planetfall Season pass
  • Stellaris: Lithoids
  • Age of Wonders: Planetfall - Revelations
  • Cities: Skylines - After Dark
  • Stellaris: Necroids
  • Imperator: Rome - Magna Graecia
  • Stellaris: Federations
  • Hearts of Iron IV: La Resistance
  • Victoria 2
  • Victoria 2: A House Divided
  • Victoria 2: Heart of Darkness
  • Cities: Skylines
  • Crusader Kings II: Way of Life
  • Crusader Kings II: Horse Lords
  • Stellaris: Synthetic Dawn
  • Crusader Kings II: Conclave
  • Stellaris
  • Hearts of Iron IV: Cadet
  • Crusader Kings II: Reapers Due
  • Stellaris: Digital Anniversary Edition
  • Stellaris: Leviathans Story Pack
  • Hearts of Iron IV: Together for Victory
  • Stellaris - Path to Destruction bundle
  • Cities: Skylines - Mass Transit
Update: See bottom paragraph

Just bought the game, played for a few hours as Iceni, everything was fine, had good framerate the whole time and no issues until the game suddenly freezes. Closed the game as it had frozen. Restart the game and there is no audio (for any part of my computer not just I:R) and very low fps (about 3 to 5 fps) which is weird because up until now everything ran fine. The low framerate persists into the main menu.

Pretty sure I had a similar issue on ck3 in which the issue was related to the audio. Checked sound settings and audio output had changed, changed it back. This resolved both the audio problem and the framerate problem for ck3, so I had expected it to work for I:R too. This solved the issue of audio although there is now a persistently low framerate even in the main menu.

I've tried verifying game files, reinstalling, starting a new game, reinstalling again but deleting all the game files as well, restarting my computer, reinstalling Microsoft Visual C++, updating game drivers. Been looking through forums to see if anyone has had a similar issue but searches for low fps come up with issues related to specs which I don't have (as stated above, the game ran fine up until this)

Edit: Did another complete reinstall and the game seems to crash on first launch after a reinstall. This happened when I reinstalled before but drew it up to chance, happened again after another reinstall so maybe that means something. Not sure though.

Been looking online for people with a similar problem but can't seem to find anything, not sure what to do at this point.

Another Edit: did one more reinstall to make sure I did it right, deleted files in Documents/Paradox Interactive/Imperator and steamapps/common/ImperatorRome as well as verifying game files after reinstall. Made sure firewall let it pass through etc etc. Based on previous reinstallations, game seems to crash on first two launches after reinstall. Framerate also seems to be around 6 fps both in menu and in game, whether paused or not. Days seem to pass by at a pretty good speed despite low framerate.

Attached files for dxdiag and all that.

Remembering that I had the same issue on ck3, I ran ck3 to find the same persistent 6 fps on there too, leading me to think the crash changed something on my computer rather than in the game's files, although I have no clue what. No framerate issue with stellaris though. The framerate issue persists with age of wonders: planetfall though.

Update: I've done a system restore to before Imperator:Rome was first installed, looks like this may have solved the problem as Age of Wonders: Planetfall now runs fine. (smooth fps, before I couldn't even get past the first loading screen). Will test ck3 and imperator (ck3 needs to update workshop mods and imperator needs to be installed again).

CK3 now runs fine, expecting I:R to run fine when it installs as well. While tinkering with stuff I remembered that this would happen on ck3 when the game would sometimes freeze, I would click on something then it would crash. The freeze would often pass if I didnt click on anything and just let it do its thing, so if anyone else has a similar issue, when the game freezes just let it do its thing, if its permanently stuck or it crashes then idk. If the crash messes up your paradox games/you got no audio then make sure you got the right audio output under sound settings. Not sure what exactly the crash changes so if this doesnt fix it then system restore to before the crash.

Imperator:Rome seems to be working fine. No crash on startup. No 6 fps.

Summary: I have (seemingly) fixed the problem. Issue was (Freeze > Close game > No audio + low fps). Solution: Change audio channel back to what it was before (speakers, headphones, whatever). This should at least fix the audio. If horribly low fps persists, system restore is the solution (to before crash). I'd recommend that if the game freezes, don't click anything, just let it sort itself out, unless it persists for a very long time.
 

Attachments

  • DxDiag.txt
    119,6 KB · Views: 0
  • pdx_settings.txt
    5,6 KB · Views: 0
  • system.log
    933 bytes · Views: 0
  • error.log
    6,7 KB · Views: 0
Last edited: