• Crusader Kings III Available Now!

    The realm rejoices as Paradox Interactive announces the launch of Crusader Kings III, the latest entry in the publisher’s grand strategy role-playing game franchise. Advisors may now jockey for positions of influence and adversaries should save their schemes for another day, because on this day Crusader Kings III can be purchased on Steam, the Paradox Store, and other major online retailers.


    Real Strategy Requires Cunning

Fimbulwolf

Recruit
23 Badges
Aug 9, 2020
1
0
  • Stellaris: Galaxy Edition
  • Age of Wonders: Planetfall - Revelations
  • Age of Wonders: Planetfall
  • Stellaris: Apocalypse
  • Stellaris: Humanoids Species Pack
  • Age of Wonders III
  • Stellaris: Synthetic Dawn
  • Stellaris - Path to Destruction bundle
  • Stellaris: Leviathans Story Pack
  • Stellaris: Digital Anniversary Edition
  • Europa Universalis IV: Rights of Man
  • Stellaris: Galaxy Edition
  • Stellaris
  • Europa Universalis IV: Common Sense
  • Europa Universalis IV: El Dorado
  • Cities: Skylines
  • Warlock 2: The Exiled
  • The Showdown Effect
  • Magicka
  • Europa Universalis IV: Wealth of Nations
  • Europa Universalis IV: Conquest of Paradise
  • Europa Universalis IV: Art of War
Was trying to play AoW3. Logged on through the AoW3 launcher, hosted a game and then lost connection from the lobby and could not connect into multiplayer. Tried to restarted the game and when I tried to log on through the AoW3 launcher, I got the message that I could not connect with server. I have tried uninstalling and reinstalling the game, logging in with both firewall on and off and have tried to log on a different computer, but always gives the message that it could not connect with servers. Is there any fix for this problem?
 

thepotshotkid

Recruit
Aug 10, 2020
1
0
I am having the same problem. Lost connection when I was searching for a game, and suddenly I cannot connect to multiplayer. Please advise.