• Pre order now!

    Paradox Development Studio brings you the sequel to one of the most popular strategy games ever made! Crusader Kings III is soon upon us and you can pre order it today!


    Releasing September 1st 2020

GingrSpiceOrDie

Recruit
9 Badges
Mar 2, 2020
3
0
  • Stellaris
  • Stellaris: Galaxy Edition
  • Stellaris: Galaxy Edition
  • Stellaris: Galaxy Edition
  • Tyranny: Archon Edition
  • BATTLETECH
  • Surviving Mars
  • Age of Wonders III
  • BATTLETECH: Flashpoint
Recently bought this game with a friend. Neither of us can connect to servers at login screen to play together. Even tried to disable firewall, that didnt work. We are both located state side in NY and Colorado, so I know location shouldnt be the issue. Anyone know any work arounds?

(Create Triumph account/register product wont connect to servers)
 

smeagolheart

Recruit
2 Badges
Nov 12, 2018
1
0
  • Age of Wonders: Planetfall Sign Up
  • Crusader Kings II: The Old Gods
Same here, can't play because it won't log in.

Can we make it where the darn game doesn't have to verify anymore if they aren't going to keep the servers up.
 

Saenomae

Recruit
5 Badges
Mar 2, 2020
1
0
  • Knights of Pen and Paper +1 Edition
  • Magicka
  • Teleglitch: Die More Edition
  • Stellaris
  • Age of Wonders III
Same here its simply down I thought it was an issue with being unable to register an account and searched everywhere until I had a friend verify the servers are just simply down

Would appreciate some kind of word on when this would be resolved cause I apparently decided to buy the game on the exact moment that it is down
 

FNE_Lightning

Recruit
4 Badges
Mar 5, 2020
2
0
  • Hearts of Iron IV: Cadet
  • Hearts of Iron IV: Together for Victory
  • Hearts of Iron IV: Death or Dishonor
  • Age of Wonders III
I still cannot connect to servers since monday. My roommates cannot either. We are in Florida, our friend we want to play online with is in South Carolina. He can connect just fine, but we can't get into the servers at all. Please help!
 
Last edited:

AndrewT

The Full Monty Python
Paradox Support Rep
Super Moderator
Moderator
106 Badges
Jun 29, 2001
68.197
1.790
  • The Kings Crusade
  • Europa Universalis IV: Wealth of Nations
  • For The Glory
  • Gettysburg
  • Hearts of Iron III
  • Heir to the Throne
  • Impire
  • Europa Universalis III Complete
  • King Arthur II
  • Knights of Pen and Paper +1 Edition
  • Lead and Gold
  • Legio
  • Leviathan: Warships
  • Europa Universalis IV: Conquest of Paradise
  • Lost Empire - Immortals
  • Magicka
  • Majesty 2 Collection
  • March of the Eagles
  • Europa Universalis III Complete
  • Naval War: Arctic Circle
  • Pirates of Black Cove
  • Europa Universalis IV: Res Publica
  • Europa Universalis: Rome
  • Rome Gold
  • Sengoku
  • Age of Wonders: Planetfall Sign Up
  • Crusader Kings II: Sunset Invasion
  • Ancient Space
  • Arsenal of Democracy
  • Hearts of Iron II: Armageddon
  • Cities in Motion
  • Cities in Motion 2
  • Crusader Kings II
  • Crusader Kings II: Charlemagne
  • Crusader Kings II: Legacy of Rome
  • Crusader Kings II: The Old Gods
  • Crusader Kings II: Rajas of India
  • Crusader Kings II: The Republic
  • Crusader Kings II: Sons of Abraham
  • A Game of Dwarves
  • Crusader Kings II: Sword of Islam
  • Commander: Conquest of the Americas
  • Darkest Hour
  • Dungeonland
  • East India Company Collection
  • Europa Universalis III
  • Europa Universalis III: Chronicles
  • Europa Universalis III Complete
  • Divine Wind
  • Europa Universalis IV
@Jordi Engel are you aware of a general problem in this area? Or is it just affecting this one user?
 

Jordi Engel

Lt. General
Feb 18, 2019
1.578
59
With the way AoW3 handles the multiplayer the issue is likely located with him or his friend, however I've not worked on AoW3 and wouldn't know how to troubleshoot connection issue. Tapping in @ArnoutS as he usual does that.