Cannot launch Majesty 2 after installing Kingmaker; cannot install Battle of Ardania

  • Crusader Kings II Expansion Subscription

    Subscribe to the CK II Expansion and enjoy unlimited access to 13 major expansions and more!


  • Crusader Kings III Available Now!

    The realm rejoices as Paradox Interactive announces the launch of Crusader Kings III, the latest entry in the publisher’s grand strategy role-playing game franchise. Advisors may now jockey for positions of influence and adversaries should save their schemes for another day, because on this day Crusader Kings III can be purchased on Steam, the Paradox Store, and other major online retailers.


    Real Strategy Requires Cunning

unmerged(307454)

Private
1 Badges
Apr 26, 2011
12
0
  • Majesty 2
I'm having so much problems trying to install this game!!! I wonder if anyone else is also having these technical problems or am I just unlucky???? X_X:wacko::wacko::wacko:
Anyway, my OS is Windows XP, tried to install the Kingmaker expansion, I passed the installation phase, but then I cannot launch Majesty 2 afterwards, I get a little loglo on the start menu/task bar with Majesty 2 printed on it, but nothing whatsoever happens afterward, I have to force stop it using task manager (showing that it's running correctly)...don't know what's the cause or how to fix it...(could anyone please help me out on this one?)

Then, I gave up so I completely uninstalled everything, reinstalled the base Majesty 2: Fantasy Kingdom and tried to install Battle of Ardania instead (along with the patch 1.4.356 because I heard that this patch will fix the crash problem associated with BoA), but whenever I tried to do that, either BoA or the patch, I get an error message stating:

Setup was unable to create the directory "C:\Program Files\Paradox Interactive\Majesty 2\Majesty2.exe"
Error 183: Cannot create a file when that file already exists.

It turned out that there's already an Majesty2.exe application program generated when I installed the base Majesty 2: Fantasy Kingdom. And this name conflicts with the directory folder which BoA and the patch tries to generates. I have always thought that as long as the file type is different, identical name wouldn't be an issue, at least it always worked when I name a .pdf and a .doc file with the same name, apparent this isn't the case with directory folder and .exe application. So how do I work around this problem???? (other than changing the name of Majesty2.exe application because I tried that and after installation, I can't launch the game at all)
PLEASE HELP!!! I REALLY WANT TO PLAY MAJESTY 2!!!! T________T TTTHHHAAAAANNNNKKKKKK YYYYYYYOOOOOOOUUUUUUUUUU!!!!!!!!!!!!

Update: I just tried to install Monster Kingdom, and it didn't work either due to the exact same name conflict problem for BoA and the patch (*banging my head on the table >___<*)
 
Last edited:

unmerged(307454)

Private
1 Badges
Apr 26, 2011
12
0
  • Majesty 2
Gosh, I wish the developers would change directory folder's name generated from those expansion applications from the conflicting Majesty2.exe to something like Majesty2MonExp, Majesty2ArdExp, Majesty2KingExp or something of the sort....this shouldn't be a hard fix, right??
 

unmerged(319373)

Recruit
1 Badges
May 23, 2011
4
0
  • Majesty 2 Collection
Same problem

I am experiencing the same problem. I downloaded eerything all at once through Steam, and after its installed, i get the exact same result of it "playing" without actually showing anything other than on the bar at the bottom and on task manager. After HOURS of forum searching, ive gotten nothing useful out of it. Ive emailed both Steam and Paradox with no response. This sucks!!
 

Kallocain

Executive Producer
22 Badges
Aug 3, 2009
3.688
452
  • Divine Wind
  • Mount & Blade: Warband
  • Supreme Ruler 2020
  • Sword of the Stars
  • Sengoku
  • Rome Gold
  • Majesty 2 Collection
  • Magicka
  • The Kings Crusade
  • Legio
  • Lead and Gold
  • Heir to the Throne
  • Hearts of Iron III
  • Europa Universalis III Complete
  • Europa Universalis III Complete
  • Europa Universalis III Complete
  • Victoria 2
  • 500k Club
  • Crusader Kings II: Holy Knight (pre-order)
  • Hearts of Iron: The Card Game
  • Rise of Prussia
  • Hearts of Iron IV Sign-up
It might be a permission issue. Please try to run the setup as administrator (by right clicking and selecting that, just being logged in as admin is not enough).
If that does not help, you could also reinstall the game, but outside of program files.