BATTLETECH - Game doesn't start

  • Crusader Kings III Available Now!

    The realm rejoices as Paradox Interactive announces the launch of Crusader Kings III, the latest entry in the publisher’s grand strategy role-playing game franchise. Advisors may now jockey for positions of influence and adversaries should save their schemes for another day, because on this day Crusader Kings III can be purchased on Steam, the Paradox Store, and other major online retailers.


    Real Strategy Requires Cunning

homemdosgalos

Recruit
15 Badges
Jul 22, 2020
3
0
  • Cities: Skylines
  • Cities: Skylines - After Dark
  • Cities: Skylines - Mass Transit
  • BATTLETECH
  • Age of Wonders: Shadow Magic
  • BATTLETECH - Digital Deluxe Edition
  • Cities: Skylines - Parklife Pre-Order
  • Cities: Skylines - Parklife
  • Shadowrun Returns
  • Shadowrun: Dragonfall
  • Shadowrun: Hong Kong
  • BATTLETECH: Flashpoint
  • Prison Architect
  • BATTLETECH: Season pass
  • BATTLETECH: Heavy Metal
One line summary of your issue
Game doesn't start

What platform are you running the game on?
Steam

What operating system do you use?
windows 10 Home

Which version of the game are you running?
latest version

What DLC do you have installed?
Flashpoint, Urban Warfare, Heavy Metal

Please explain your issue is in as much detail as possible.
Good Evening,
i can't start the game. I've managed to play it perfectly fine up until i reinstalled it a few days ago.

Everytime i try to play it, it goes straight to the Battletech Launcher (never happened before). I've tried to hit play and went through all the options available.

I tried do restart steam, a clean uninstall of the game, even tried to run it on safe mode, all no joy. I tried to play the .exe file from the game's folder as well.

I have all the DLC's (and the game worked fine with all of them), and running the game on vanilla, never had a mod in this game. Some help please?

Edit: forgot to mention. I am running Windows 10 and no specific app that would cause any interference with the game (just Battletech and the Steam launcher), an i never used nor installed mods, 100% vanilla.

Any Help?

Have you tried verifying your files?
Yes

Steps to reproduce the issue


Attach DxDiag (PC), System Info log (Mac), or run sudo lshw -html > specs.html and uploaded specs.html (Linux)
File(s) attached

Attach Output Log
Windows: \Users\YourUserName\AppData\LocalLow\Harebrained Schemes\BATTLETECH\output_log.txt
Mac OS: Users >{name} > Library > Logs > Unity > Player.log
Linux: ~/.config/unity3d/Harebrained Schemes/BATTLETECH/Player.log

File(s) attached

If the game crashed, please attach the crash file with the time stamp closest to the crash.
Windows: [Steam library folder]\steamapps\common\BATTLETECH\DumpBox
For v.17 and beyond try here: C:\Users\[YourUserName]\AppData\LocalLow\Harebrained Schemes\BATTLETECH
OSX: Macintosh HD > Users > [username] > Library > Application Support > Steam > steamapps > common > BattleTech > DumpBox
Linux: [Steam library folder]/steamapps/common/BATTLETECH/DumpBox

File(s) attached

If a save game was loaded at the start of the game session, upload it. Please make sure to upload the save game with the timestamp closest to when you loaded it.
Windows:
Steam: [Steam installation folder]\userdata[SteamID]\637090\remote\C0\SGS1
GOG: 'C:\Users\USER_ID\AppData\Local\GOG.com\Galaxy\Applications\50593543263669699\Storage\Shared\Files\C#\SGS#'
Vanilla:'C:\Users\USER_ID\AppData\LocalLow\Harebrained Schemes\BattleTech\C#\SGS#'
OSX:
Steam: Macintosh HD > Users > [username] > Library > Application Support > Steam > userdata > [SteamID] > 637090 > remote > C#> SGS#
GOG: Macintosh HD > Users > [username] > Library > Application Support > GOG.com > Galaxy > Applications > 50593543263669699 > Storage > Shared > Files > C# > SGS#
Vanilla: Macintosh HD > Users > [username]> Library > Application Support > unity.Harebrained Schemes.BattleTech > C# > SGG#
Linux:
Steam: /home/.steam/steam/userdata/[steamID]/637090/remote/C#/SGS#
GOG: /home/[username]/.config/unity3d/Harebrained Schemes/BATTLETECH/remote/C#/SGS#/
Vanilla: /home/[username]/.config/unity3d/Harebrained Schemes/BATTLETECH/remote/C#/SGS#/

File(s) attached

Attach screenshot / video
File(s) attached
 

Attachments

  • output_log.txt
    14,4 KB · Views: 0
Upvote 0

AndrewT

The Full Monty Python
Paradox Support Rep
Super Moderator
Moderator
114 Badges
Jun 29, 2001
74.377
2.726
  • Leviathan: Warships
  • Europa Universalis IV: Wealth of Nations
  • Europa Universalis IV: Call to arms event
  • For The Glory
  • Gettysburg
  • Hearts of Iron III
  • Heir to the Throne
  • Impire
  • Europa Universalis III Complete
  • King Arthur II
  • Knights of Pen and Paper +1 Edition
  • Lead and Gold
  • Legio
  • Europa Universalis IV: Conquest of Paradise
  • The Kings Crusade
  • Lost Empire - Immortals
  • Magicka
  • Majesty 2 Collection
  • March of the Eagles
  • Europa Universalis III Complete
  • Naval War: Arctic Circle
  • Pirates of Black Cove
  • Europa Universalis IV: Res Publica
  • Europa Universalis: Rome
  • Rome Gold
  • Crusader Kings III
  • Crusader Kings II: Sunset Invasion
  • Ancient Space
  • Arsenal of Democracy
  • Hearts of Iron II: Armageddon
  • Cities in Motion
  • Cities in Motion 2
  • Crusader Kings II
  • Crusader Kings II: Charlemagne
  • Crusader Kings II: Legacy of Rome
  • Crusader Kings II: The Old Gods
  • Crusader Kings II: Rajas of India
  • Crusader Kings II: The Republic
  • Crusader Kings II: Sons of Abraham
  • A Game of Dwarves
  • Crusader Kings II: Sword of Islam
  • Commander: Conquest of the Americas
  • Darkest Hour
  • Dungeonland
  • East India Company Collection
  • Europa Universalis III
  • Europa Universalis III: Chronicles
  • Europa Universalis III Complete
  • Divine Wind
  • Europa Universalis IV
There’s no evident cause of that problem in there, I’m afraid, no error or crash. Very odd.

the nVidia driver looks old so may as well update it.

If that doesn’t help, Please try a **clean** reinstall:

- Remove the game from Steam (uninstall)
- Manually delete all these files and folders, if still there:

C:\Program Files (x86)\Steam\steamapps\common\BattleTech\
C:\Users\USERNAME\AppData\LocalLow\Harebrained Schemes\
C:\Program Files (x86)\Steam\userdata\USER_ID\637090\
(first move the \remote\C#\SGS#\ folder elsewhere to keep your save games)

- Install the game again
- add steam.exe and BattleTech.exe to the Whitelist of your antivirus app, whatever it is

If you still get any problem, please send me a new dxdiag.txt and output_log.txt , thank you.