Age of Wonders: Planetfall - Update V1.404 "Triceratops 2"

  • We have updated our Community Code of Conduct. Please read through the new rules for the forum that are an integral part of Paradox Interactive’s User Agreement.

DireDave

Dire Penguin Overlord
QA
Triumph Studio Dev
1 Badges
Jun 12, 2018
463
86
  • Age of Wonders: Planetfall Sign Up
TricetopsCover.png


Hello Commanders,

Over the last few months, we have seen many new Empires arise and flourish. From Dvars taming Tyrannodons to Shakarn riding mechs; every commander seeks their own way towards glory. Those victories are not without setbacks; sometimes caused by issues that are outside of a commander's power to fix. This is where we come in with another update!

As mentioned in our 'Mission Accomplished' debriefing, active development of Age of Wonders: Planetfall has ended but we are committed to supporting the game where necessary. We want to thank everyone for the continued support and feedback on the forums! While our active presence in the community has ramped down; we still regularly check incoming posts and reports.

Meanwhile, we are hard at work on new exciting things and while having no announcements at PDXCon, we will be participating in a couple of Panels! Check out the PDXCon Remixed Agenda for details. See you there!

Stay tuned and enjoy, Commanders!

V1.404 - Update Notes

Fixes:
Galactic Empires
  • The Psi-Fish Hunting Grounds planet trait now forces the planet to be continents and disallows changing of game settings to prevent issues with Psi-Fish dwelling spawns.
  • Fixed the Masking Frequencies planet trait not working
  • Fixed not being able to choose the default Phoenix Walker requisition item as Vanguard, Amazon, Shakarn or Syndicate
  • Fixed not being able to buy high level vehicles using Renown in certain situations

Combat
  • Fixed evasion bonus from the Skitter ability not resetting after Undo
  • Fixed Undo allowing you to circumvent the effects of Panic and Captivate
  • Fixed that applying Impaired on a unit would reset cooldowns and once per combat abilities from the disabled mods
  • Fixed a crash that occurred when you would Undo a move in combat after moving away from a hazard

Campaign
  • Fixed issue where campaign missions could sometimes not be ended
  • Fixed that the Forgotten NPC Faction would sometimes not be present in the Obolus-5 campaign mission

General
  • Fixed that the Futurist achievement could no longer be unlocked
  • Fixed issue where buying a grail cypher from an NPC faction would not deduct its influence cost
  • Fixed occupied Shakarn and Oathbound colonies having access to previously built turret defenses unlike the other races
  • Fixed Soul Beacon Maelstrom not giving Essence Charges to friendly units
  • Fixed issue where operations that are being primed would not update when the amount of casting points available changed
  • Fixed an exploit caused by repeatedly aborting the production of a Colonizer unit
  • Fixed an exploit related to the Immaculate Breeding Ground Emergent spawn
  • Fixed that certain actions and events could end up blocking the victory screen (both in the Galactic Empire and scenarios)
  • Fixed multiplayer going out of sync by viewing the invasion forces in the Diplomacy screen
  • Fixed a crash that could happen during an AI turn in the late game
  • Fixed various instances where the AI could get stuck in their turn (which would leave you stuck at “Opponents are moving”).
  • Fixed issues with higher quality settings on M1-based Macs
 
Last edited:
  • 25Like
  • 6Love
  • 1
Reactions:
Wow! Thanks, it was unexpected.
Can you also fix exploit with one-shot operation (like Mass Driver Cannon) when you attack with some scout enemy stack, kill an expensive unit and surrender? Possible way to fix: add start on cooldown for such operation (2-3 combat rounds).
 
  • 2
  • 1
Reactions:
Windows 7 x64
Steam.
I have this red triangle.

View attachment 717038

I have re-checked integrity. Files are OK.
No mods intalled.
Sounds like it might be related to the launcher. Can you launch the game by going to Properties>Local Files and then starting it through AoWPF.exe? Usually that should do the trick.

If that does work; try re-installing the launcher through these steps:
  1. - Exit the Steam app entirely
  2. Uninstall Paradox Launcher v2 from the Windows "Apps and features" utility, if still present.
  3. Delete the following folders if still present:
    • %LocalAppData%/Programs/Paradox Interactive/
    • %LocalAppData%/Programs/Paradox Interactive//Paradox Interactive/
    • %Appdata%/Paradox Interactive/launcher-v2/
    • (To see the AppData folder you'll need to enable View Hidden Items in File Explorer)
  4. Run steam.exe as the Windows Admin user
  5. Run the game from the PLAY button in Steam
Hope that helps!
 
  • 1
Reactions:
If that does work; try re-installing the launcher through these steps:
  1. - Exit the Steam app entirely
  2. Uninstall Paradox Launcher v2 from the Windows "Apps and features" utility, if still present.
  3. Delete the following folders if still present:
    • %LocalAppData%/Programs/Paradox Interactive/
    • %LocalAppData%/Programs/Paradox Interactive//Paradox Interactive/
    • %Appdata%/Paradox Interactive/launcher-v2/
    • (To see the AppData folder you'll need to enable View Hidden Items in File Explorer)
  4. Run steam.exe as the Windows Admin user
  5. Run the game from the PLAY button in Steam
Having the same problem, but on MacOS. Ran fine today before the update, but launching the game failed. Do you have similar steps for MacOS?
 
Sounds like it might be related to the launcher. Can you launch the game by going to Properties>Local Files and then starting it through AoWPF.exe? Usually that should do the trick.

If that does work; try re-installing the launcher through these steps:
  1. - Exit the Steam app entirely
  2. Uninstall Paradox Launcher v2 from the Windows "Apps and features" utility, if still present.
  3. Delete the following folders if still present:
    • %LocalAppData%/Programs/Paradox Interactive/
    • %LocalAppData%/Programs/Paradox Interactive//Paradox Interactive/
    • %Appdata%/Paradox Interactive/launcher-v2/
    • (To see the AppData folder you'll need to enable View Hidden Items in File Explorer)
  4. Run steam.exe as the Windows Admin user
  5. Run the game from the PLAY button in Steam
Hope that helps!
I have done it.
Launcher is re-installed.
Still the same. I have never experienced anything like this.
Maybe I should delete the game and reinstall it?
 
Having the same problem, but on MacOS. Ran fine today before the update, but launching the game failed. Do you have similar steps for MacOS?
I believe for Mac, it's simply a case of removing the files related to the launcher from the Application folder and then re-installing it. Are you able to launch the game by directly launching the application from the installation folder? Would be good to know for sure if it's related to the launcher or the game.

I have done it.
Launcher is re-installed.
Still the same. I have never experienced anything like this.
Maybe I should delete the game and reinstall it?
Might be good to try that; however were you able to run the game by simply launching the game through AoWPF.exe? Or does that also fail?
 
  • 1
  • 1Like
Reactions:
I believe for Mac, it's simply a case of removing the files related to the launcher from the Application folder and then re-installing it. Are you able to launch the game by directly launching the application from the installation folder? Would be good to know for sure if it's related to the launcher or the game.


Might be good to try that; however were you able to run the game by simply launching the game through AoWPF.exe? Or does that also fail?
I tried but failed.
I launch it!
Recipe:
1. Find file XINPUT1_3.dll (same directory with AowPF.exe)
2. Copy it
3. Rename the copy to XINPUT1_4.dll
Now it works
Yep!!! it launched! ) Thanx, Pavel!
 
Nice! Happy to hear about the fixes to skitter. We were seeing some insane numbers in our mp games XD

I'm pretty sure Sinsling submitted a bug report saying that the Shakarn propagator effects were not being triggered when they are not the main defender in an attack (if the attacker engages your ally, and you get pulled into the fight, then the boons weren't being applied to any allied units).

I'll be watching the panels at pdxcon, so cya there!
 
Thanks for the Update! Glad to see continued commitment to this amazing game.
If I may, I'd like to request a Quality of Life feature, I'd very much like to set the starting tech in custom games and multiplayer. I've gotten a taste of starting on teir 3 tech thanks to Empire mode, and would very much appreciate the option to set starting tech to the desired teir in matches with my friends. This could really keep the game fresh. Thanks for reading, and I hope you consider this.
Much love.
 
I have just updated.
Launching the game failed.

Having the same problem, but on MacOS. Ran fine today before the update, but launching the game failed. Do you have similar steps for MacOS?

I have the same problem, I've reinstalled the game, but the problem still remains
AoWPF.exe fails (XINPUT1_4.dll not found)

The proper fix for the launch issues should now be live! Let me know if it works or not.
 
I've been playing the game for months with friends and Monday night was the last time were able to play. Since the new update, we haven't been able to successfully play Multiplayer again. The game crashes to desktop without option to report anything whenever we try to play Multiplayer. Sometimes it crashes in the lobby, sometimes while joining a lobby. Literally unplayable. We all bought the game on the Microsoft Store, and unlike the people who bought the game on Steam, we had no problems with the launcher. We've tried pretty much everything from 'repair' to uninstalling entirely and reinstalling. We all also made sure Windows updates are up to date as well as graphics drivers. Please help, we're all busy and only have a few hours a week to play.