Results 1 to 2 of 2

Thread: Problem with mount and blade multiplayer in steam

  1. #1

    Exclamation Problem with mount and blade multiplayer in steam

    Hello, I've bought Mount ant blade with fire ant sword on steam, I tried to acces multiplayer, it says that I have to enter serial code. I`ve did it, but it says that it's wrong

  2. #2
    A bunny with a hat Moderator Nikolai II's Avatar
    200k clubArsenal of DemocracyHearts of Iron 2: ArmageddonDeus VultEast India Company Collection
    Divine WindFor The GloryGalactic AssaultHearts of Iron IIIHeir to the Throne
    Europa Universalis III: In NomineIron CrossLost Empire - ImmortalsEU3 Napoleon's AmbitionVictoria: Revolutions
    Europa Universalis: RomeSemper FiSword of the StarsSupreme Ruler 2020 GoldRome: Vae Victis
    Hoi 2 Beta500k clubEuropa Universalis IV

    Join Date
    Nov 2001
    Location
    Chateau Maison, Sweden
    Posts
    9,078
    Have you tried to right-click on the game in your steam launcher and select "view key" and then used that key?

    (I guess so since you have registered the game here, but it never hurts to ask)

    If you have, then you need to go to Taleworlds and mail their support, and they can fix it for you. (They have had many steam key issues before)
    FSM! I am convinced. Are you?
    IPU! I have faith. Do you?

    GENERATION 33: The first time you see this, copy it into your sig on any forum and add 1 to the generation. Social experiment.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts