Results 1 to 5 of 5

Thread: Weird Message problem

  1. #1

    Weird Message problem

    Hi MB community!

    I've been playing the game for some time now and I wanted to replay it to obtain some of the missing steam achievements, but everytime I play for... let's say, 30 - 40 minutes, the "world messages" like "Some of your soldiers are ready to upgrade" dissapear and never come back.

    I can't play without those, but the missing info just pisses me off. The only way I found to reverse the effects is to exit the game and start it again. Do you know any other way to fix that? maybe a key or something... having to restart the game every 30 - 40 minutes really destroys the atmosphere and immersion. Thank you.

  2. #2
    This happens when the message log is overloaded. Waiting RL time is the only thing that clears the buffer, aside from restarting the game.

    Also, this typically only happens if there are script errors that are spamming the message log. If you click 'Notes' and go to Recent Messages, you'll see all the messages that should have been scrolling on your screen. If you have a slew of script errors, you've found your true culprit and can start looking for solutions. (There shouldn't be any such script error bugs in the current 1.153 Native, so I'd guess if this is the case you are using a mod?)

  3. #3
    Yes, I'm using Native mod compilation 1.0.

    Strangely enough, I have never seen a script error message while playing this one. The next time it happens I will have a look at recent messages. I see myself restarting this mod until I get tired of it, tbh.
    I'm going to post here what I found (In case i find anything).

    Thanks For

    EDIT:

    Okay, so it happened again, clicke notes, went to recent messages and found this err: SCRIPTERROR ON CODE 921: Invalid overlay ID: 474 LINE NO 42
    after this there are 5 identical messages: AT_script update_agent_hp_bar
    And then another script error which is pretty much the same as before but on code 922 instead of 921 and this time in line 161; followed by the update agent hp bar message like 6 times.

    So I guess that the problem is something doesn't work well with HP bars, but they're not enabled in my game so I'm just lost. Any help?
    Last edited by Kaede11; 13-06-2012 at 12:29.

  4. #4
    That's been a common complaint with that mod, that is as of yet without solution there.

    I might suggest using Floris Gameplay (or Expanded) for a similar (and more featured) experience without the spammed errors.

  5. #5
    So it has no solution. Well, thank you. I'm downloading Floris Expanded but it's a shame having to start again.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts