+ Reply to Thread
Results 1 to 3 of 3

Thread: Game freeze(Windows 7 x64)

  1. #1
    Infamy: 39/30 Sn3ipen's Avatar
    Cities in Motion 2Crusader Kings IICommander: Conquest of the AmericasDeus VultEU3 Complete
    Divine WindHeir to the ThroneKing Arthur IIMagickaNaval War: Arctic Circle
    Rome GoldVictoria 2Victoria II: A House DividedVictoria II: Heart of DarknessRome: Vae Victis
    Mount & Blade: WarbandWarlock: Master of the ArcaneMount & Blade: With Fire and SwordPride of NationsCK2: Holy Knight
    500k clubEuropa Universalis IV: Pre-orderEUIV: Wealth of NationsEUIV: Conquest of ParadiseEUIV: Res Publica
    Crusader Kings II: Legacy of RomeCrusader Kings II: Sword of IslamCrusader Kings II: The Old GodsCrusader Kings II: Sons of Abraham

    Join Date
    Apr 2011
    Location
    Tromsų, Norway @69°North
    Posts
    1,007

    Game freeze(Windows 7 x64)

    I thought I should start a new thread, since everybody else that have this kind of issue seem to have WinXP 32Bit.

    The game start to freeze when I play on maps with lots of units. It start to gets slow with time compression 1:05 and get somewhat better when i set it to 1:1.

    Especially in C01S09: North by Northwest, since thats how far i have come because of this issue.

    I believe I tried everything. I checked the integrity in steam and even tried to set NWAK.exe to high priority in "Task Manager" and tried to turn off every thinkable background process(even the web browser!), but the result is the same all over.

    Links to logs:
    DxDiag.txt
    output_log.txt
    TTG_NAVALWAR_LOG2012-04-15.txt

    This was from my latest game that lasted for about 30 minutes in C01S09. Deleted TTG_NAVALWARLOG before I tried to take a test run, to make it shorter.

    I couldn't find The Comms log so there haven't been any issues with internet.

    I came across this one in "output_log.txt", I tried to search The forums and compared other peoples log files to mine, but I couldn't find anyone with this:

    Code:
    HandleD3DDeviceLost
      HandleD3DDeviceLost: still lost
    Skipped rendering frame because GfxDevice is in invalid state (device lost)
     
    (Filename: C:/BuildAgent/work/b0bcff80449a48aa/Runtime/Misc/Player.cpp Line: 1593)
    Can this have something to with a faulty DirectX installation or GPU-drivers on my machine? I think its not my drivers. See explanation under this.

    and this!
    Code:
    Unloading 94 unused Assets to reduce memory usage. Loaded Objects now: 16094. Operation took 551.801562 ms.
    That is a lonoog time to unload 31 unused assets compared to the the beginning of this game.

    Thanks for any help.

    Edit:
    I tried to run a test in a mission where i didn't have any problems(Tutorial 3 - Air Strike) and I couldn't find anything wrong in the logs, even if i had it at 1:20, during almost the whole mission.

    DxDiag.text

    TTG_NAVALWAR_LOG2012-04-15.txt:

    Warning - 4:35:46 PM.357 ** GameData->CreateUnit: Unit [FMP] (NATO Airport) spawned on low ground and is moved up. Height 276m
    Warning - 4:35:46 PM.456 ** GameData->CreateUnit: Unit [GIH] (NATO Airport) spawned on low ground and is moved up. Height 131m
    Warning - 4:35:59 PM.444 ** ExecuteEventTriggers: Trigger EventTrigger PlayerDetectsEnemy Role:IsAircraft 1Inner Triggers
    Warning - 4:36:08 PM.665 ** ExecuteEventTriggers: Trigger EventTrigger OrderReceivedFromPlayer OrderType: LaunchAircraft
    Warning - 4:36:28 PM.872 ** BaseUnit::MoveToNewPosition3D -> distance to move is <= 0, but actual speed is > 0! Unit:Boeing KC-767 GNG Distance:0M, Speed:851KPH
    Warning - 4:36:32 PM.58 ** BaseUnit::MoveToNewPosition3D -> distance to move is <= 0, but actual speed is > 0! Unit:Boeing KC-767 GNG Distance:0M, Speed:851KPH
    Warning - 4:37:06 PM.421 ** BaseUnit::MoveToNewPosition3D -> distance to move is <= 0, but actual speed is > 0! Unit:Boeing KC-767 GNG Distance:0M, Speed:200KPH
    Warning - 4:38:00 PM.86 ** BaseUnit::MoveToNewPosition3D -> distance to move is <= 0, but actual speed is > 0! Unit:Boeing KC-767 GNG Distance:0M, Speed:200KPH
    Warning - 4:38:15 PM.616 ** BaseUnit::MoveToNewPosition3D -> distance to move is <= 0, but actual speed is > 0! Unit:NH90 NFH GOJ Distance:0M, Speed:260KPH
    Warning - 4:38:39 PM.375 ** ExecuteEventTriggers: Trigger PlayerObjective EventTrigger CountEnemyRoleDestroyedEqualsOrHigher TUT_TUTORIAL3_P1_VICCON_PLAYER_AIR Role:IsAircraft Victory Condition
    Warning - 4:39:15 PM.804 ** BaseUnit::MoveToNewPosition3D -> distance to move is <= 0, but actual speed is > 0! Unit:Boeing KC-767 GNG Distance:0M, Speed:200KPH
    Warning - 4:39:20 PM.508 ** BaseUnit::MoveToNewPosition3D -> distance to move is <= 0, but actual speed is > 0! Unit:AIM-120D AMRAAM Missile Distance:0M, Speed:4900KPH
    Warning - 4:39:20 PM.522 ** BaseUnit::MoveToNewPosition3D -> distance to move is <= 0, but actual speed is > 0! Unit:AIM-120D AMRAAM Missile Distance:0M, Speed:4900KPH
    Warning - 4:39:20 PM.538 ** BaseUnit::MoveToNewPosition3D -> distance to move is <= 0, but actual speed is > 0! Unit:AIM-120D AMRAAM Missile Distance:0M, Speed:4900KPH
    Warning - 4:39:49 PM.521 ** BaseUnit::MoveToNewPosition3D -> distance to move is <= 0, but actual speed is > 0! Unit:F-35C FRM Distance:0M, Speed:850KPH
    Warning - 4:40:03 PM.43 ** BaseUnit::MoveToNewPosition3D -> distance to move is <= 0, but actual speed is > 0! Unit:Eurofighter Typhoon GLI Distance:0M, Speed:850KPH
    Warning - 4:40:09 PM.833 ** BaseUnit::MoveToNewPosition3D -> distance to move is <= 0, but actual speed is > 0! Unit:F-35C FSO Distance:0M, Speed:850KPH
    Warning - 4:40:22 PM.322 ** BaseUnit::MoveToNewPosition3D -> distance to move is <= 0, but actual speed is > 0! Unit:F-35C FRM Distance:0M, Speed:850KPH
    Warning - 4:40:32 PM.385 ** BaseUnit::MoveToNewPosition3D -> distance to move is <= 0, but actual speed is > 0! Unit:F-35C FSO Distance:0M, Speed:850KPH
    Warning - 4:40:39 PM.770 ** BaseUnit::MoveToNewPosition3D -> distance to move is <= 0, but actual speed is > 0! Unit:F-35C FRM Distance:0M, Speed:850KPH
    Warning - 4:40:58 PM.255 ** BaseUnit::MoveToNewPosition3D -> distance to move is <= 0, but actual speed is > 0! Unit:NH90 NFH GOJ Distance:0M, Speed:260KPH
    Warning - 4:41:41 PM.733 ** BaseUnit::MoveToNewPosition3D -> distance to move is <= 0, but actual speed is > 0! Unit:Boeing KC-767 GNN Distance:0M, Speed:851KPH
    Warning - 4:41:54 PM.473 ** BaseUnit::MoveToNewPosition3D -> distance to move is <= 0, but actual speed is > 0! Unit:NH90 NFH GOJ Distance:0M, Speed:260KPH
    Warning - 4:41:59 PM.729 ** BaseUnit::MoveToNewPosition3D -> distance to move is <= 0, but actual speed is > 0! Unit:F-35C FWW Distance:0M, Speed:1200KPH
    Warning - 4:42:03 PM.260 ** BaseUnit::MoveToNewPosition3D -> distance to move is <= 0, but actual speed is > 0! Unit:Boeing KC-767 GNN Distance:0M, Speed:851KPH
    Warning - 4:42:03 PM.661 ** ExecuteEventTriggers: Trigger PlayerObjective EventTrigger CountEnemyRoleDestroyedEqualsOrHigher TUT_TUTORIAL3_P1_VICCON_PLAYER_SURFACE Role:IsSurfaceCombattant Victory Condition


    and btw: I really like this game allot. Its the freshest thing I've been playing for a long time.
    Last edited by Sn3ipen; 15-04-2012 at 17:04.

  2. #2
    Turbo Tape Games Dev JanH's Avatar
    Naval War: Arctic Circle

    Join Date
    Jan 2011
    Location
    Bergen, Hordaland, Norway, 106562399381316, Bergen, Hordaland
    Posts
    2,408
    Thanks for feedback and logs.

    We're continuing to optimize memory and performance. In very large scenarios, a bit of a performance hit will necessarily happen when a lot of things happen simultaneously on high time compression, but not as bad as you describe it.

    I think "GfxDevice is in invalid state (device lost)" mostly happens if you Alt-Tab away from the game or minimize it during play. This should not be a problem.

  3. #3
    Infamy: 39/30 Sn3ipen's Avatar
    Cities in Motion 2Crusader Kings IICommander: Conquest of the AmericasDeus VultEU3 Complete
    Divine WindHeir to the ThroneKing Arthur IIMagickaNaval War: Arctic Circle
    Rome GoldVictoria 2Victoria II: A House DividedVictoria II: Heart of DarknessRome: Vae Victis
    Mount & Blade: WarbandWarlock: Master of the ArcaneMount & Blade: With Fire and SwordPride of NationsCK2: Holy Knight
    500k clubEuropa Universalis IV: Pre-orderEUIV: Wealth of NationsEUIV: Conquest of ParadiseEUIV: Res Publica
    Crusader Kings II: Legacy of RomeCrusader Kings II: Sword of IslamCrusader Kings II: The Old GodsCrusader Kings II: Sons of Abraham

    Join Date
    Apr 2011
    Location
    Tromsų, Norway @69°North
    Posts
    1,007
    I tried to "set affinity" to "cpu0" as described in another thread and it actually helped If I set 3DView to off, it actually became playable in that big mission. I guess I have to get used to it, for a while, untill you guys have solved the problem. To bad I can't hear the sound of the engine and explosion's when 3D is turned off. I know I got a crappy computer, but it meets the requirements as they are described on Steam.

    I was actually thinking about installing XP on another partition to see if that could help(more RAM), until I came to the bug report forum and it sounds like they got bigger issues than I have. I also discovered that I got Ram Left when I am playing, so thats not the issue.

    Thank you for your time, you are doing an amazing jobb!
    Last edited by Sn3ipen; 15-04-2012 at 19:19.

+ Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts