+ Reply to Thread
Results 1 to 7 of 7

Thread: Can't start Majesty 2 after installing Battles of Ardania

  1. #1

    Can't start Majesty 2 after installing Battles of Ardania

    Hi,

    i purchased the game "Majesty 2" & the add-on "kingmaker" on steam and it worked very well. Then I purchased the add-on "Battles of Ardania" and now the game does not start any more.
    My girlfriend has the same problem.
    I contactet your support and sent my dx-diag files but since Mar-17 2011 16:05 there is no respond to my request. I asked for a feedback but the support just remains silent.
    I am very patient but it's not to much if i ask for a little feedback and to send me an answer like "We know the problem" or "We are working on it"

  2. #2
    Hey Graufang. I'm sorry you're having some trouble. Everything seems to be working for me on steam, but i know that's no help to you. I sent you a PM with my email, can you email me the details. We'll get this worked out.

    Some people on the steam forums found
    "Issue was solved by installed Majesty 2 on the same hard-drive as the OS"

    If anyone is still having problems send me a PM.
    Last edited by Andrew_C; 25-03-2011 at 15:45.

  3. #3
    I have the same problem, and I would love to send you a pm but I don't seem to be authorized to do that, or I don't know how. I assumed I could do it from your profile since there is nowhere else to go, but I can't view it. I registered the game, no change. Also, steam can only install games to the steam folder, so unless we want to move our entire collection to the os hd, the solution you found is of no help.

  4. #4
    tried doing that. still wont work.. the vanilla game worked tho

  5. #5
    Not working for me either. Trying to reinstall Majesty 2 without it... oh well... at least it was only $5... last expansion I buy for that game...

  6. #6
    One year after the first bug report and still no fix yet! What are you doing at Paradox?

    This is the last time I bought a game from you... I'm very disappointed.

  7. #7
    It's not Paradox fault. Well, it is, to some extent. But You cannot blame them solely for the problem.

+ Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts