+ Reply to Thread
Page 6 of 7 FirstFirst ... 4 5 6 7 LastLast
Results 101 to 120 of 129

Thread: Majesty (Gold edition) help thread

  1. #101
    Is this esoteric? Demi Moderator Dumble Dwarf's Avatar
    Majesty 2

    Join Date
    Jul 2007
    United States
    Quote Originally Posted by psychomc View Post
    I have Majesty Gold and a few years ago i could trouble-free play both, the normal game and the extension.
    Since then only my hardware has changed...
    What's the new hardware? I'm guessing that is the reason it doesn't work. Perhaps one of the hardware drivers is choking when it gets to that particular instruction.

  2. #102
    And just to clarify, did you try the suggestion in post #97? The original problem for what it's for doesn't seem to be totally like yours, but the Maj working and MajX not seems to be similiar.

  3. #103

    I have a problem I am trying to solve and I was wondering if anyone here could help.
    I have majesty 1 and the expansion installed as well as the gold edition.

    Now my problem is my gold edition has music but the original majesty 1 + expansion doesnt.

    1 + expansion has less problems than the gold edition so I would prefer to use it and play the extra levels available for download with it too.

    I tried dragging majesty golds music folder into my majesty 1 + expansion folder and it wont play

    So im trying to work out whats going on, for people who have majesty 1 + expansion and your music works:

    1) Are your music files called the following?

    Are they in a folder called Music which is located in the same directory as Majesty.exe?

    I would appreciate any help

    Note: My majesty 1 + expansion folder never had a music folder in the first place I don't know if I deleted it or it never existed in the first place.
    Last edited by John551; 22-03-2010 at 22:21.

  4. #104
    Oh well, I found out there is a "Musictracks.txt" that is in the data folder of gold and tells the game the names of the music tracks to play, I just copied that and it worked, but only if I use the gold exe, I wonder if that will give that building limitation problem.. the downloaded quest works though.
    Last edited by John551; 23-03-2010 at 14:44.

  5. #105
    I'm having an issue with the Steam version of Majesty Gold.

    For those unaware, when you buy Majesty + NE in Steam you only get one game listed - Majesty Gold. When you double click on that in Steam it gives you another dialog and you choose between launching Majesty or Majesty: NE.

    Here is my issue. I am having crashing problems and want to try the .bat method of fixing it since I'm running a quad-core processor. However, when I try and create a .bat file to run MajX.exe, it opens up the original Majesty instead of the NE.

    When I go into my Steam files, there is a separate folder for Majesty and for Majesty: NE, however, both Majesty.exe and MajX.exe in their respective folders open up the original Majesty.

    The only way that I can see to get into the NE is to open the game from Steam and then choose NE in the extra dialog box. However, I have no idea what .exe file this is pulling from since running MajX.exe directly opens up the original Majesty.


  6. #106
    MajX.exe IS the expansion. It runs properly on Steam on Win 7 x64 here, so give more info. You might want to just reinstall also, in case something's awry on your side.

  7. #107
    Quote Originally Posted by DorthLous View Post
    MajX.exe IS the expansion. It runs properly on Steam on Win 7 x64 here, so give more info. You might want to just reinstall also, in case something's awry on your side.
    I understand that MajX.exe is supposed to be the expansion, but when I run MajX.exe from the Steam folder it runs the original Majesty, no expansion. The only way I can find to run the expansion is to open the game through Steam itselft. Since MajX.exe doesn't open the expansion, I can't create a .bat file that launches the game using only one core.

    I'm assuming this is only a problem with the Steam version. I suppose I can try and reinstall but my brother-in-law is having the same exact issues on a quad-core processor using Windows 7 (same as me).

    Sorry if I wasn't clear before. Since you are using a similar setup, can you try and launch MajX.exe through the Steam folder and tell me if it launches the Northern Expansion or the original Majesty? The directory should be something like C:\Program Files (x86)\Steam\steamapps\common\majesty gold edition\MajX\MajX.exe

  8. #108
    Hmm, that's a nice bug you've found. Since it calls back to Steam to have the permission, Steam authorizes with default value, aka Majesty, the shell doesn't carry the proper info. This should be brought to Steam attention. On another note, I am in a rush here, so I can't check if you did what I am about to suggest, but if not, do it.

    -Exit Steam.
    -Locate the Steam app and through the properties, make it run as administrator (don't just flag the shortcut, this works sometimes when the shortcut doesn't, guess Steam can restart itself or something).
    -ALSO flag any and all exe in Majesty gold folder with run as administrator.
    -Try launching.

    If not, I'll look more into it for you later seeing as it works for me. Can you just confirm first that you have x64? not x86? Also, I installed Majesty before from... gamer's gate I think? Or some other download site, so this might be a hint too. Good luck and post as much info as you can.

    Reread, you said you're having a crash problem? When? Info please. Also, look higher in the thread for a possible codec solution, a possible registry solution and try and just take out everything in the music folder as well. GL

  9. #109
    Thank you for all the tips.

    Unfortunately it will be a couple days before I am able to troubleshoot this some more but I figured I could answer a couple of your questions.

    1. Yes, I am running 64-bit Windows 7 Pro.

    2. It crashes randomly during gameplay, not during the intro movie or anything. Sometimes I can play for over an hour before it crashes to desktop, sometimes it's only 10 minutes.

    Looking at my event viewer, it appears that I'm getting two different errors:

    Error 1:
    Faulting application name: MajX.exe, version:, time stamp: 0x465fa571
    Faulting module name: AcXtrnal.DLL, version: 6.1.7600.16385, time stamp: 0x4a5bd98a
    Exception code: 0xc0000374
    Fault offset: 0x00008518
    Faulting process id: 0xfc0
    Faulting application start time: 0x01cad2b9a4c94fa8
    Faulting application path: c:\program files (x86)\steam\steamapps\common\majesty gold edition\MajX\MajX.exe
    Faulting module path: C:\Windows\AppPatch\AcXtrnal.DLL
    Report Id: 02738651-3ead-11df-8ef9-00248cd10f03

    Error 2:
    The program Majesty.exe version stopped interacting with Windows and was closed. To see if more information about the problem is available, check the problem history in the Action Center control panel.
    Process ID: 490
    Start Time: 01cad275c574afc9
    Termination Time: 28
    Application Path: c:\program files (x86)\steam\steamapps\common\majesty gold edition\Majesty\Majesty.exe
    Report Id:

  10. #110
    This really has nothing to do with the launcher. Try common troubleshoot steps, especially if you are able to play sometime with 2 tracks of music (switches between one and the other without crash) or even better, if you can complete some games:

    -update drivers (or read up if those drivers have known issues, sometime a downgrade is a temporary solution). Make sure to CLEAN the previous drivers first. Two versions overlapping CAN screw up some time.

    -update directX.

    -update any other part of your computer you might need, no matter if it looks relevant or not (i.e.: network drivers or bios [make sure you know what you do for a bios, if not skip it. Better a dead game than a dead comp])

    -google those error codes, look on any majesty forum see if you can trace them.

    -If you can, at some point, full system reinstall (or try to run it on another comp)

    -Check for overheat issue, especially for random crashes in a game.

    -ALSO THIS GAME IS KNOWN TO RANDOMLY CRASHES AFTER A WHILE. So if this takes a long period or is infrequent, save or autosave and suck it up.

  11. #111
    First Lieutenant Cliff60's Avatar
    Arsenal of DemocracyDarkest HourElven Legacy CollectionFor the MotherlandHearts of Iron III
    Iron CrossSemper FiSengokuVictoria 2

    Join Date
    Jan 2010
    Hampshire uk
    Im using win7. with geforce 9200. No probs with the movie at all. I just get CDT all the time. it just says its stopped working. But i have been able to play about half the missions so far. only had the game a week. But cant play the expansion. It starts ok but cant build anything even on the beginers missions. As soon as i place the building i get swarms of trolls attack it and kill my peasants before they can even start building it. a troll will sit outside my castle and kill anything that tries to leave it. I deleted all the music cause it was causing the game to lock up. that solved that prob. Compatabilty mode doesnt stop the CTD. But think thats a win7 prob cause i have probs with every game CTD. Out of the 30 games ive got only HOI2 collection works without any probs

  12. #112
    Again, Win 7 isn't the culprit, although maybe your installation is. Win 7 is, by what I can see, a more stable and compatible system than even XP.

  13. #113
    ok i played the game on a Windows 7 Ultimate 64-bit with a GTX260 with a dulecore and 4Gb of ram and i got it working
    1st install the game then before ya play it go to start then run tape in "MSCONFIG"
    then when you got the System Configuration window up click on the "boot" tab at the top
    then click on the "Advanced options"
    then click on the "Number of Processors" box and set it to 1
    then reboot ya pc once ya done that the game works hope this help.

    when ya finnish run MSCONFIG agine go to the "general" tab and select "Normal startup"
    then reboot to get ya seytem back up to %100 work with old games as well

    no need to do anything to the game files or anything els just becarefull in the Seytem Configuration seem my mate try it and click on the roung thing lol

  14. #114
    Argh, why would you ever do that?
    Instead create a shortcut to the app and in the target, use something like that:

    C:\Windows\System32\cmd.exe /C start /AFFINITY 4 D:\Steam\steamapps\common\simcit~1\Apps\SimCit~1.e xe

    without quotes and replacing paths and application names by what they need to be. If you don't know the ms-dos 8 char name of a file or folder, open CMD through run, use cd <path> to move around and use dir /x to show the content of a directory both as 8 char names and long names. Good luck and don't cripple your comp, it isn't made to run on only a fragment of its cores, especially recent cpus.

    (Replace '4' by the core number you want to use, where 1 is the first, 2 the second, etc.)

  15. #115
    my way have ya dulecore or quods to run on one Processor but its can be reversed before ya go on another game.

    DorthLous way is to have just the game running through 1 Processor core without changeing the boot nice.

    do DorthLous way 1st people at least his way ya dount have to reboot ya pc lol

  16. #116

    Lightbulb ???????

    Okay, I'm looking at this thread and thinking. "What have people Done?" My Majesty Gold works fine on windows 95, 98, XP, Vista and 7 ((x64) multi-core) Without any special configuration. And the music works. And the wrath of Krolm stuff works.

    THE ONLY problem is with any installation (of mine) is that the scroll is SUPER FAST (I Have tried disabling fast scroll, it doesn't work (this also affects the mission selection screen)).

    How about we do what the community did with Warzone 2100 and get the source files???

    If any body wants I might upload a download link to the EXEs or something if you want.

  17. #117
    fix for scroll speed:

    turn off fast scrolling in the options menu from majesty.

    start > run > regedit

    HKEY_CURRENT_USER -> Software -> CyberLore -> Majesty there will be an entry called "ScrollSpeed".

    standard value = 20
    change it to 2 or something and it will scroll slower

    now dont adjust any scrolling options in the options menu because that will reset it.

    have fun

  18. #118
    Quote Originally Posted by Dreeej View Post
    fix for scroll speed:

    turn off fast scrolling in the options menu from majesty.

    start > run > regedit

    HKEY_CURRENT_USER -> Software -> CyberLore -> Majesty there will be an entry called "ScrollSpeed".

    standard value = 20
    change it to 2 or something and it will scroll slower

    now dont adjust any scrolling options in the options menu because that will reset it.

    have fun
    Thanks, that has totally fixed it. I changed it to five which is much more reasonable

  19. #119
    Hello everybody.

    I love this wonderful game and come back to it from time to time.

    So I have this Gold Edition. Recently I set up Windows 7 Ultimate, and tried to launch Majesty, which was installed on previous Win XP. You see, I have Nvidia 7600 GT video, and I remember the game won't work with any drivers higher than 94.XX. That wasn't a problem in XP, but those drivers won't install in 7.

    So I scrolled through this nice thread, came across post #97, gave it a shot and it worked, despite of 260.99 driver.

    So here I am, playing it, having a good time and getting ready to unlock Master Quests. I played for the whole day, left couple of missions from Expansion for the next time, instead enjoyed Vengeance of the Liche Queen from the Original. Next time I start Majesty victories are erased.

    Guys, is there a way to fix this thing?


  20. #120
    Quote Originally Posted by Analad View Post
    Ok finally I find some time. Anyway there's a possibility I found a solution to your problem:
    • You need have launch once Majesty and MajXP.
    • Then launch regedit, take EXTREME caution in Regedit, the save is automatic and you can break your computer.
    • Search Cyberlore, until you find something like a folder with this name.
    • Inside there's 2 folders, Majesty and Majesty Expansion.
    • Open Majesty then right click, create, key.
    • Name the key you create: InstallShield
    • Select the new InstallShield folder.
    • Then right click, create, String value
    • The name for the String value you create: INSTALLPATH
    • Double click INSTALLPATH and inside its value enter the windows path to Majesty folder, for example: C:\Games\Majesty Gold\Majesty

    That should do the trick.

    EDIT: One thing I forget, it's possible that in Regedit you don't have the Majesty folder in Cyberlore. Then Launch it again and change a preference like the sound level, quit Majesty and this should have create the stuff in registry. Then you can try the steps above.
    Not really working as well as it could. Instead of a faceless error message, the game complains that it can't load various data files(even though they're right there and the registry points to the right place). Then we get to the start screen, with no interface beyond the clickable pits of picture. Click any, and it complains again and quits. Normal Majesty works fine. I'll say this is without the CD: I had it but it's gone missing. Majesty ran fine without it, and I think the Northern Expansion used to, but this is a backup of those files-the computer needed a reformat due to viral infection. Majesty works, the Northern Expansion doesn't.

    What an annoyance.

+ Reply to Thread
Page 6 of 7 FirstFirst ... 4 5 6 7 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts