+ Reply to Thread
Page 5 of 7 FirstFirst ... 3 4 5 6 7 LastLast
Results 81 to 100 of 129

Thread: Majesty (Gold edition) help thread

  1. #81
    Recruit Jasey's Avatar
    Majesty 2

    Join Date
    Oct 2009
    Location
    On a mystical island.
    Posts
    7
    If you right click on an orig majesty icon then go to properties, you can use the compatability mode to increase the likelyhood of success... it may still go awry but at least you can play right!

  2. #82
    Quote Originally Posted by Frein View Post
    It's pretty amazing. How can the gold version be so different from the original to not allow those quests to work? It can't be a very complicated operation to make them work.
    It was an extremely simple fix. I beta tested a Wrath of Krolm fix for Cyberlore but they never released it. They never even made a fix for Balance of Twilight which would have been equally simple. Funds were drying up and additional support for the game was being discontinued. The Gold bugs with game freezes and the music files were never corrected for the same reason. At that time, I knew that no additional corrections were being made to Gold. They didn't even release the working patch to Wrath of Krolm that I had on my PC. I have since lost it. For that reason I bought an extra copy of the original game I found in a bargain bin just in case my original game was ever damaged - because Gold just flat didn't work for me with the game freezes and music problems. I have only one copy of the Northern Expansion. Fortunately, the patches and extra quests are still online for those us who have the original game and expansion. At this stage most of Cyberlore's dwindling resources were directed toward getting a publisher for Majesty 2 which they were beginning to develop. They even announced development on their old forums and posted some initial pics of the game. They were never successful in finding a publisher.

    Irronically, today I installed Majesty and MajX on my brand new Windows 7 Core i7 rig. The games both run. I have had no errors. But performance is terrible. The game is terribly unresponsive to selecting build items from the menu and setting attack and explore flags. The Balance of Twilight quest for NE installed fine but sadly Win 7 found that the Wrath of Krolm quest was incompatible and would not install it. You get what you get. This is an old unsupported game.

  3. #83
    Yeah they also need to fix the frame rate.. it's so slow on vista.

    So anyways for the people who are crying out for balance.

    ... the.. game.. is.. easy... anyways. i don't have any troubles with it.

  4. #84
    Who's crying for balance?

    It's hard to switch back though... I was playing Shards of Brashnards yesterday, and I so wanted to build an Outpost to save my Barbs and build an Agrela temple so I could have healing/resurrection... I ended up with 4 graveyards - that's 56 dead heros!

  5. #85
    Lt. General Hassat Hunter's Avatar
    Majesty 2Warlock: Master of the Arcane

    Join Date
    Jul 2007
    Location
    The Netherlands
    Posts
    1,359
    You were?

    (Well, I wouldn't say "crying" but whatever)

  6. #86
    "people" usually means more than one...

  7. #87
    Private m0rp's Avatar
    Crusader Kings IIHearts of Iron IIIVictoria 2500k clubEuropa Universalis IV

    Join Date
    Apr 2009
    Location
    High Germany
    Posts
    19
    Hello guys, I have a strange problem with Majesty 1.41 (without expansion).
    Every time after I played Majesty and restarted my PC, everything looks normal, it loads and then, when the vista symbol should appear, the screen wents completely black and doesn't change this, so I have to shut my computer down manually by the start button.
    Next time I start my PC, the resolution has changed to 800x600 (or even 640x480, I'm not sure) and 16 bit colours and I have to put it on 1280x1024 again and reorganise my desktop. Unfortunatelly, this happens every time after playing Majesty .

    My system is: Vista 32bit, GTX 280, 3GB RAM, Intel Quad Core Q9550

    Does anyone have an idea what could cause this strange bug and how I can fix it?

  8. #88
    I have that same problem on my backup computer (a POS pre-built). The resolution is changing to 800x600 and 16 bit colors because that's what the original Majesty plays in. I don't know why the settings stay after you restart but they do for me as well. The easiest solution for me was to play version 1.0 (unpatched) in Windows 95 compatibility mode, but honestly I didn't spend a lot of time looking for solutions so there may be a better way. Have you tried compatibility mode or adding -nointro to your Majesty icon? You may also find success by going into your bios, disabling your graphics card, and enabling on board graphics. I've been able to get a few older 2D games to run properly by using integrated graphics instead of a beefy card.

  9. #89
    You know I already own a physical Majesty Gold copy. But if they would fix these compatibility issues an make the downloadable quests work with Gold I would probably rebuy the game from the digital download outlets. It's not completely unheard of either since know something like this was done for the Steam version of X-Com making it work with Vista.

  10. #90
    About a year ago, I downloaded Majesty Gold, remembering the fun I had with the original, even though my negligence lost the CD. Great, so I had fun playing that. Unfortunately, my computer got fried and the hard-drive is not qualified to run. As a consequence, I lost all my games on it, including Majesty Gold. Recently, I found a USB device that can hook up directly to the hard-drive and add it in as a sort of very large memory stick, to be reference by my new computer. I managed to restore most of my games by pulling them from the old hard-drive, including Majesty Gold. Oddly, Majesty works but Majesty Gold results in an error as soon as I try to execute it. It is not an inability to run the game as far as I can tell, and have tried running the game in various other modes to test that. I have even tried it on another computer, one with the same OS and general statistics as my original computer, but no luck. Am I just going to have to scrap Gold as something that did not survive the transfer and was fried along with the hard-drive at some point, or is there some registry or other problem that I am missing that would affect Gold but not original?

    And by Gold and Original, I mean "Majx" versus "Majesty", both using the Gold download. Majesty works, but Majx does not.

    Thanks,

    Kaldar

  11. #91
    Majesty Gold is a special version including both the original game and the expansion. Majx is the expansion. However, how do you expect us to help you without said error?

  12. #92
    Perhaps it's the windows registry he needs to update in place of the Majx/Gold installer?

    At this site: EDIT: "REMOVED AS IT SEEMS AN UNKNOWN SITE" and I don't want link a garbage.

    There are some files updating the registry for some Majesty versions... But CARE, I don't know at all if this is a serious site or not. Use it at your own risk.
    Last edited by Analad; 03-12-2009 at 08:27.

  13. #93
    BEFORE using those, please post the error. Random support can make things worst. Even good support can make it worst sometimes. So, before anything else, post your error and wait a bit.

    P.S.: Also, gold requires no patch, normally. On top of that, his normal Majesty plays fine. We really should see that message first.

  14. #94
    His last sentence clarifies his usage of the terms: He has Gold, but is using "Majesty" to denote the original and "Gold" to denote MajX. Why, I'm not sure as it's just as easy to use original and MajX in the first place

    But as to why it's not working, no idea... although it's certainly odd that half the game is working, so probably something to do with the MajX stuff.

  15. #95
    Yes, well, the "error message" was just "Microsoft has encountered an error and has been forced to crash" with absolutely nothing specific or useful.

  16. #96
    Lol, that's weird. No idea of the problem, I give a quick check and the registry is hardly the problem as the application will fill it with what it needs if the information isn't here.

    EDIT: oops, not fully, I could have found your problem, it seems there's a bug if your Registry is empty of Majesty information and when you launch the XP.
    ALAS I don't have the time right now to find a way to help you.
    Last edited by Analad; 03-12-2009 at 08:59.

  17. #97
    Ok finally I find some time. Anyway there's a possibility I found a solution to your problem:
    • You need have launch once Majesty and MajXP.
    • Then launch regedit, take EXTREME caution in Regedit, the save is automatic and you can break your computer.
    • Search Cyberlore, until you find something like a folder with this name.
    • Inside there's 2 folders, Majesty and Majesty Expansion.
    • Open Majesty then right click, create, key.
    • Name the key you create: InstallShield
    • Select the new InstallShield folder.
    • Then right click, create, String value
    • The name for the String value you create: INSTALLPATH
    • Double click INSTALLPATH and inside its value enter the windows path to Majesty folder, for example: C:\Games\Majesty Gold\Majesty

    That should do the trick.

    EDIT: One thing I forget, it's possible that in Regedit you don't have the Majesty folder in Cyberlore. Then Launch it again and change a preference like the sound level, quit Majesty and this should have create the stuff in registry. Then you can try the steps above.
    Last edited by Analad; 03-12-2009 at 10:41.

  18. #98
    Thank you! It worked!

    Of course, now I have to re-do the campaign, but I never get tired of those maps anyway.

  19. #99
    You are welcome, have a good game!

  20. #100

    Question

    I have Majesty Gold and a few years ago i could trouble-free play both, the normal game and the extension.
    Since then only my hardware has changed, i'm still using Win XP.

    Now i can play the normal game (Majesty.exe) without any problems, quests, freestyle, downloaded quests. with music and everything, without doing any of the stuff described in this thread.

    in the extension (MajX.exe) i can only play freestyle games, if i try to start a quest (no matter one of the normal game qusts or one of the northern extension), the game crashes with an error:

    MajX.exe - Application Error
    The instruction at "0x7c9112b4" referenced memory at "0x00000464". The memory could not be "read".

    After i discovered this problem, i tried everything i found in this thread, but nothing helps.
    Then i re-installed the game, restart, the same problem.
    any suggestions what else i can try?
    (its a brilliant game, but no, i dont format my hdd, re-install win or buy new hardware for this ;-) )
    i wonder whats the big difference between the normal game and the extension?

    and why can i play the normal quests with Majesty.exe and not with MajX.exe...

+ Reply to Thread
Page 5 of 7 FirstFirst ... 3 4 5 6 7 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts