Page 1 of 4 1 2 3 ... LastLast
Results 1 to 20 of 61

Thread: Beta Patch 1.0.3 Beta2 Ready - Update 26/3-08

  1. #1

    Exclamation Beta Patch 1.0.3 Beta2 Ready - Update 26/3-08

    Patch 1.0.3 Beta 2 is out. We chose to make one more beta of the patch. This should fix if not all, then most of the problems from 1.0.3 Beta 1.
    Remember to read the ATTENTION section below.

    Changelog 1.0.3 Beta 2:
    Fixed Scientists bonus not being applied properly when science was maxed.
    Mineral And Credits Sliders were not updating correctly
    Fixed a bug with trade routes calculations (they could get negative)
    Fixed a bug with minerals dissapearing (Related to building improvements)
    The +- resource statistics should now be more accurate
    Fixed several smaller bugs with the economy
    Made changes to end turn code, to hopefully fix random crashes.

    And for those who uses some of the older Intel Graphics cards which does not support Hardware T&L, we enabled the software emulation which Intel uses. Remeber that the intel card still needs Shader Model 1.1 Support.
    Futhermore when missing a prerequisite, the message in the logfile should be a little more helpfull.

    The patch files apply for version 1.0.2, which means that those of you having the 1.0.3 Beta 1 installed need to uninstall the patch first. On Vista you need to click show updates before the patch uninstall becomes visible.

    German version:
    http://updates.polluxgamelabs.com/do....0.3_Beta2.msp
    english version:
    http://updates.polluxgamelabs.com/do....0.3_Beta2.msp
    gamersgate version:
    http://updates.polluxgamelabs.com/do....0.3_Beta2.msp
    torrent for all of them:
    http://updates.polluxgamelabs.com/do...3Beta2.torrent
    ----
    Some programs (Ulead Viewer and some others) can break the file association for msp files.
    Try rightclicking the msp file, chose "open with" and select "Windows Installer".
    This can allso be done from the command prompt with the following command:
    msiexec /p pathToFilename.msp

    where pathToFilename needs to be replaced with the location of the msp file.
    -----
    Patch 1.0.3 BETA is now ready, but before you all rush out and download it please read the following:

    !ATTENTION!
    This patch is a BETA, therefore there might still be bugs and other issues.
    It is possible that you will have to reinstall the game when the final patch is released and your saves might corrupt so please be prepared for this, even if it is highly unlikely.
    If you do not want to take these risks, please wait for the final version which should be out early next week, assuming there are no major issues with the BETA patch.
    For those of you who would like to help us get the patch out as fast as possible, take a look at the change log and keep an eye out for irregularities which could be caused by the patch. Many of the performance improvements comes from only calculating income, corruption, expenses etc when they change instead of every time they are needed. So keep an eye out for numbers not updating when you get a new science, make design changes etc.
    If you discover anything patch related please start your topic with “[BETA PATCH]” so that they do not get confused with other issues.
    Enjoy the patch and thanks in advance for helping us test it!
    --
    Jonez and Kenney

    English Retail:
    Patch 1.0.0-1.0.2
    Patch 1.0.2-1.0.3 Beta

    German Retail:
    Patch 1.0.0-1.0.3 Beta
    Patch 1.0.0-1.0.2 Beta
    Patch 1.0.2-1.0.3 Beta

    GamersGate:
    Patch 1.0.2-1.0.3 Beta

    Bittorent link:
    Torrent containing all patches
    use programs like µTorrent to chose which files to download
    Last edited by kenand; 27-03-2008 at 10:01. Reason: added torrent link

  2. #2
    Private

    Join Date
    Mar 2008
    Location
    Mainz am Rhein, Germany
    Posts
    18
    okay, let´s try. and u guys get home and catch some sleep!

  3. #3
    Thank you for the dedicated effort to get this out. I appreciate the effort greatly.

  4. #4
    You guys are amazing. You all really should take a full easter leave starting friday and don't even look at the forums until tuesday. That way we will have a nice log of bugs ready for you by the time you come back.

  5. #5
    wow thats some really bad speed

    You guys really need to invest in some more bandwith.

  6. #6
    Second Lieutenant
    Lost Empire - Immortals

    Join Date
    Dec 2000
    Location
    Malmö
    Posts
    183
    Oh great! You guys go get some sleep, we till take over from here.

  7. #7
    friggen awesome guys will let u know how it goes here we go

  8. #8
    Quote Originally Posted by Tulan
    wow thats some really bad speed

    You guys really need to invest in some more bandwith.
    Well i dont think it is the bandwidth that is the problem, it should be a 100Mbps line. Probably the server

  9. #9
    Second Lieutenant
    Lost Empire - Immortals

    Join Date
    Dec 2000
    Location
    Malmö
    Posts
    183
    Since I got time while it's downloading I can as well ask how to install it

    Do I need to put the beta file in the game folder first?
    I don't recognize the .msp file format, just double click it to start?

  10. #10
    I am reminded of some of the old comedy movies with the old-style row of phone booths. An interesting story hits and dozens of reporters swarm to call it in at once, knocking over the phone bank. I suspect the bandwidth might be related to that phenomenom.

  11. #11
    Quote Originally Posted by Wan
    Since I got time while it's downloading I can as well ask how to install it

    Do I need to put the beta file in the game folder first?
    I don't recognize the .msp file format, just double click it to start?
    Just run it. It is a executed by Windows Installer. It is the Patch equivalent of msi files.

    Added a torrent link by the way. Should be a lot faster..

  12. #12
    Second Lieutenant
    Lost Empire - Immortals

    Join Date
    Dec 2000
    Location
    Malmö
    Posts
    183
    Quote Originally Posted by kenand
    Just run it. It is a executed by Windows Installer. It is the Patch equivalent of msi files.

    Added a torrent link by the way. Should be a lot faster..

    Wow! That was much faster! Thanks again.

  13. #13
    20.4kb ( remember some of those mid east undersea cables are still out so if youre on the subcontient some parts of asia and australia) youre transfer speeds are down at the moment.

    Ive got a 1mb so should be maxing 100 kb second. But check internettrafficreport.com shows theres a lot of net slowness atm. So its not u its not pollux probbaly just the bit inbetween lol

  14. #14
    Ok, I've successfully installed the GG version patch and verified that the game at least starts up and works. Will comment more tomorrow since I'm too tired to play now (Same time here in Sweden as in Denmark). Once again, awesome work.

  15. #15
    BAh patch died at 76% lol 15mb patch for 1 hour and dies, feel like i am on dialup again.

    Now the patch wont even startup downloading.

  16. #16
    erm ok GG link not working Just a heads up

  17. #17
    LOL went with the torrent and got it done in 2m

  18. #18
    Quote Originally Posted by Tulan
    BAh patch died at 76% lol 15mb patch for 1 hour and dies, feel like i am on dialup again.

    Now the patch wont even startup downloading.
    I got to 75% maybe the link is broken

  19. #19
    dang it. I can't download the .torrent file (the link opens a window which just hangs). Can someone upload the .torrent somewhere so I can get it?
    Current developer of Lost Empire: Immortals patches

  20. #20
    yeah im trying the link to the GG version same thing its starting to download now , me thinks theres a limit on the number of connected downloads - just going to leave it for an hour and see if it progresses

Page 1 of 4 1 2 3 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts